summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-01-05 18:45:41 +0100
committerPhilipp A2018-01-05 18:45:41 +0100
commit35a2368e80855e2fbd3b75609844988b092925c4 (patch)
tree011f2f621cf225c3d3c313475a7a7205efabcd26
parentd315a808319377a9b1b73f1f4cbd91d23902b187 (diff)
downloadaur-35a2368e80855e2fbd3b75609844988b092925c4.tar.gz
v0.4.3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index 24f2ec57e666..9731419a6e92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/pkg/
/src/
/*.pkg.tar.xz
-/*.tar.gz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
index 6dc9f6e62ba3..adda6bcbb518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
-# Maintainer: Phil Schaf <flying-sheep@web.de>
+# Maintainer: Philipp A. <flying-sheep@web.de>
_name=anndata
pkgname=python-$_name
-pkgver=0.3.1
+pkgver=0.4.3
pkgrel=1
pkgdesc='A data structure for rectangular numeric data and sample/variable annotations.'
arch=(any)
url="https://github.com/theislab/$_name"
license=(GPL3)
-depends=(python-pandas python-scipy)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-md5sums=('188f68b5f4f8a848bc131321b874d185')
+depends=(python-h5py python-pandas python-scipy)
+makedepends=(python-pip)
+_wheel="$_name-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
+sha256sums=('666b61fea65d8f4b75b78d444746a7b5f6c3a78346bd39f37b0d95e476e081b4')
+noextract=("$_wheel")
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ pip install --compile --no-deps --root="$pkgdir" "$_wheel"
}