summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-01-05 18:49:47 +0100
committerPhilipp A2018-01-05 18:49:47 +0100
commit6fa60d002a0d52132e82bcd7461e29bf462ef50c (patch)
treec54e1e556e3de69838371f4241d20e071c3bac4f
parent35a2368e80855e2fbd3b75609844988b092925c4 (diff)
downloadaur-6fa60d002a0d52132e82bcd7461e29bf462ef50c.tar.gz
ignore-installed
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD4
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 756c0ca72832..ebfe446ad197 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-anndata
pkgdesc = A data structure for rectangular numeric data and sample/variable annotations.
- pkgver = 0.3.1
- pkgrel = 1
+ pkgver = 0.4.3
+ pkgrel = 2
url = https://github.com/theislab/anndata
arch = any
license = GPL3
+ makedepends = python-pip
+ depends = python-h5py
depends = python-pandas
depends = python-scipy
- source = https://files.pythonhosted.org/packages/source/a/anndata/anndata-0.3.1.tar.gz
- md5sums = 188f68b5f4f8a848bc131321b874d185
+ noextract = anndata-0.4.3-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/a/anndata/anndata-0.4.3-py3-none-any.whl
+ sha256sums = 666b61fea65d8f4b75b78d444746a7b5f6c3a78346bd39f37b0d95e476e081b4
pkgname = python-anndata
diff --git a/PKGBUILD b/PKGBUILD
index adda6bcbb518..6272fce90f9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=anndata
pkgname=python-$_name
pkgver=0.4.3
-pkgrel=1
+pkgrel=2
pkgdesc='A data structure for rectangular numeric data and sample/variable annotations.'
arch=(any)
url="https://github.com/theislab/$_name"
@@ -16,5 +16,5 @@ sha256sums=('666b61fea65d8f4b75b78d444746a7b5f6c3a78346bd39f37b0d95e476e081b4')
noextract=("$_wheel")
package() {
- pip install --compile --no-deps --root="$pkgdir" "$_wheel"
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
}