summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2020-06-15 10:53:43 +1000
committerFabio Zanini2020-06-15 10:53:43 +1000
commit3fa929e05ecaa4e6c1f9b99564f479e9f3857d1e (patch)
treec7e540d1e17b13fdb00a5b67108020364196f02e
downloadaur-3fa929e05ecaa4e6c1f9b99564f479e9f3857d1e.tar.gz
First version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..993373e0a67f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-annoy
+ pkgdesc = Approximate Nearest Neighbors in C++/Python optimized for memory usage and loading/saving to disk.
+ pkgver = 1.16.3
+ pkgrel = 1
+ url = https://github.com/spotify/annoy
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = python
+ source = https://files.pythonhosted.org/packages/00/15/5a9db225ebda93a235aebd5e42bbf83ab7035e7e4783c6cb528c635c9afb/annoy-1.16.3.tar.gz
+ sha256sums = fe2779664bd8846f2d67191a7e6010b8df890ac4586336748fd0697f31654379
+
+pkgname = python-annoy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc7b66dda490
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Fabio Zanini <fabio.zanini@fastmail.fm>
+pkgname=python-annoy
+_pkgname=annoy
+pkgver=1.16.3
+pkgrel=1
+pkgdesc="Approximate Nearest Neighbors in C++/Python optimized for memory usage and loading/saving to disk."
+url="https://github.com/spotify/annoy"
+arch=('i686' 'x86_64')
+license=("Apache")
+depends=('python')
+source=("https://files.pythonhosted.org/packages/00/15/5a9db225ebda93a235aebd5e42bbf83ab7035e7e4783c6cb528c635c9afb/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('fe2779664bd8846f2d67191a7e6010b8df890ac4586336748fd0697f31654379')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ python setup.py install --prefix=/usr --root="$pkgdir/"
+}