summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcqzw5552024-03-27 09:33:18 +0800
committercqzw5552024-03-27 09:33:18 +0800
commit0ea0b0b371b97c8adcaa6a77b979cfd974021fbf (patch)
tree53528929317dfe6beae305c3a5e8b2e61055555f
parent5c282d8e254941d0fbd306d1d9a2a776d3bd6bff (diff)
downloadaur-0ea0b0b371b97c8adcaa6a77b979cfd974021fbf.tar.gz
PEP 517 installation
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD15
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 305011ac3fcd..866c7ad578fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-ansicolors
pkgdesc = ANSI colors for Python
pkgver = 1.1.8
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/jonathaneunice/colors
arch = any
license = ISC
- checkdepends = python-pytest
- makedepends = python-setuptools
+ checkdepends = python-nose
+ makedepends = python-build
+ makedepends = python-installer
depends = python
source = https://github.com/jonathaneunice/colors/archive/c965f5b9103c5bd32a1572adb8024ebe83278fb0/python-ansicolors-c965f5b9103c5bd32a1572adb8024ebe83278fb0.tar.gz
sha512sums = f60770496614b75fc2a6bab15c55a87c245ac233c907708572e76d4701690895b3a350b7ab2934304262a8e9076fbff64a9792c2345fe5994af0c6c09209e6a2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..83c3fb4c12cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.pkg.tar.zst
+*.pkg.tar.xz
+*.tar.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 519f4a766d49..785bb012fb94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,33 @@
pkgname=python-ansicolors
pkgver=1.1.8
_commit=c965f5b9103c5bd32a1572adb8024ebe83278fb0
-pkgrel=6
+pkgrel=7
pkgdesc="ANSI colors for Python"
url="https://github.com/jonathaneunice/colors"
license=('ISC')
arch=('any')
depends=('python')
-makedepends=('python-setuptools')
-checkdepends=('python-pytest')
+makedepends=('python-installer' 'python-build')
+checkdepends=('python-nose')
source=("https://github.com/jonathaneunice/colors/archive/$_commit/$pkgname-$_commit.tar.gz")
sha512sums=('f60770496614b75fc2a6bab15c55a87c245ac233c907708572e76d4701690895b3a350b7ab2934304262a8e9076fbff64a9792c2345fe5994af0c6c09209e6a2')
build() {
cd colors-$_commit
- python setup.py build
+ python -m build --wheel --no-isolation
+ # python setup.py build
}
check() {
cd colors-$_commit
- python -m pytest
+ nosetests
+ # python -m pytest
}
package() {
cd colors-$_commit
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ # python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
}