summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2020-09-02 21:24:11 +0000
committerFelix Yan2020-09-02 21:24:11 +0000
commitb426ec23bdfcf146b51c2a585a6b6720a1d233c9 (patch)
tree1276674d90bf9c484f9259c0bb234259c4c5ef0f
downloadaur-b426ec23bdfcf146b51c2a585a6b6720a1d233c9.tar.gz
addpkg: 1.1.8-1
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41a6b748889f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python-ansicolors
+pkgver=1.1.8
+_commit=c965f5b9103c5bd32a1572adb8024ebe83278fb0
+pkgrel=1
+pkgdesc="ANSI colors for Python"
+url="https://github.com/jonathaneunice/colors"
+license=('ISC')
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("https://github.com/jonathaneunice/colors/archive/$_commit/$pkgname-$_commit.tar.gz")
+sha512sums=('f60770496614b75fc2a6bab15c55a87c245ac233c907708572e76d4701690895b3a350b7ab2934304262a8e9076fbff64a9792c2345fe5994af0c6c09209e6a2')
+
+build() {
+ cd colors-$_commit
+ python setup.py build
+}
+
+check() {
+ cd colors-$_commit
+ python -m pytest
+}
+
+package() {
+ cd colors-$_commit
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+}