summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Oliver2020-03-31 17:07:22 +0100
committerBen Oliver2020-03-31 17:07:22 +0100
commit0fcbc7fcbe02ee1341d155a09910c28549769034 (patch)
treefc15261548d51635fd932ecb291e03fd09cdd916
downloadaur-0fcbc7fcbe02ee1341d155a09910c28549769034.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9292892f273
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-ansiwrap
+ pkgdesc = textwrap, but savvy to ANSI colors and styles
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = https://github.com/jonathaneunice/ansiwrap
+ arch = any
+ license = Python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-textwrap3
+ source = https://files.pythonhosted.org/packages/source/a/ansiwrap/ansiwrap-0.8.4.zip
+ md5sums = 0e24741bda593b7bd2162c3e3bd3b8ba
+
+pkgname = python-ansiwrap
+ depends = python
+ depends = python-textwrap3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fed90e8f8087
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ben Oliver <ben@bfoliver.com>
+
+pkgbase='python-ansiwrap'
+pkgname=('python-ansiwrap')
+_module='ansiwrap'
+pkgver='0.8.4'
+pkgrel=1
+pkgdesc="textwrap, but savvy to ANSI colors and styles"
+url="https://github.com/jonathaneunice/ansiwrap"
+depends=('python' 'python-textwrap3')
+makedepends=('python-setuptools')
+license=('Python')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.zip")
+md5sums=('0e24741bda593b7bd2162c3e3bd3b8ba')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}