summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-20 08:10:05 +0300
committerDimitris Kiziridis2020-07-20 08:10:05 +0300
commit4eed4451a61f9a37d8821a49c372f94d8b00d9b1 (patch)
tree01cd560ae8ed21be077ed718b72c42a62325f3a6
downloadaur-4eed4451a61f9a37d8821a49c372f94d8b00d9b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD47
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2135a9270fdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-anyconfig
+ pkgdesc = Generic access to configuration files in any formats (to be in the future)
+ pkgver = 0.9.11.r0.ga24c2c2
+ pkgrel = 1
+ url = https://github.com/ssato/python-anyconfig
+ arch = any
+ license = MIT
+ checkdepends = python-tox
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ provides = python-anyconfig
+ provides = python2-anyconfig
+ conflicts = python-anyconfig
+ conflicts = python2-anyconfig
+ source = python-anyconfig::git+https://github.com/ssato/python-anyconfig
+ sha256sums = SKIP
+
+pkgname = python-anyconfig-git
+ depends = python
+
+pkgname = python2-anyconfig-git
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..004b970c8cef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgbase='python-anyconfig'
+pkgname=('python-anyconfig-git' 'python2-anyconfig-git')
+pkgver=0.9.11.r0.ga24c2c2
+pkgrel=1
+pkgdesc='Generic access to configuration files in any formats (to be in the future)'
+url='https://github.com/ssato/python-anyconfig'
+arch=('any')
+license=('MIT')
+provides=('python-anyconfig' 'python2-anyconfig')
+conflicts=('python-anyconfig' 'python2-anyconfig')
+makedepends=('python'
+ 'python-setuptools'
+ 'python2'
+ 'python2-setuptools')
+checkdepends=('python-tox')
+source=("${pkgname%-git}::git+https://github.com/ssato/python-anyconfig")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd python-anyconfig
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/RELEASE_//'
+}
+
+build() {
+ cd python-anyconfig
+ python setup.py build
+ python2 setup.py build
+}
+
+package_python-anyconfig-git() {
+ depends=('python')
+ cd python-anyconfig
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.MIT "${pkgdir}/usr/share/licenses/python-anyconfig-git/LICENSE"
+}
+
+package_python2-anyconfig-git() {
+ depends=('python2')
+ cd python-anyconfig
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ mv "${pkgdir}/usr/bin/anyconfig_cli" "${pkgdir}/usr/bin/anyconfig_cli2"
+ mv "${pkgdir}/usr/share/man/man1/anyconfig_cli.1" "${pkgdir}/usr/share/man/man1/anyconfig_cli2.1"
+ install -Dm644 LICENSE.MIT "${pkgdir}/usr/share/licenses/python2-anyconfig-git/LICENSE"
+}
+# vim:set ft=sh ts=2 sw=2 et: \ No newline at end of file