summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-21 20:56:02 +1100
committerPumpkinCheshire2020-11-21 20:56:02 +1100
commit1a0621c02455d59ac3388c06fca646191e549fc6 (patch)
tree65afdaf0922639b882c7227183eecf03dbf32be6
downloadaur-1a0621c02455d59ac3388c06fca646191e549fc6.tar.gz
init 0.1.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc8ef8e506f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-anyconfig-msgpack-backend
+ pkgdesc = a backend module for python-anyconfig to support to load and dump MessagePack data files.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/ssato/python-anyconfig-msgpack-backend
+ arch = any
+ license = MIT
+ depends = python-anyconfig
+ depends = python-msgpack
+ source = https://files.pythonhosted.org/packages/source/a/anyconfig-msgpack-backend/anyconfig-msgpack-backend-0.1.1.tar.gz
+ sha256sums = 223c3619dbb4eb433360494b0560f3694e5fa0dd69032db65e8c5318597bb348
+
+pkgname = python-anyconfig-msgpack-backend
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac4b8c73b6a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+
+_name=anyconfig-msgpack-backend
+pkgname=python-$_name
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='a backend module for python-anyconfig to support to load and dump MessagePack data files.'
+url='https://github.com/ssato/python-anyconfig-msgpack-backend'
+arch=('any')
+license=('MIT')
+depends=('python-anyconfig' 'python-msgpack')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('223c3619dbb4eb433360494b0560f3694e5fa0dd69032db65e8c5318597bb348')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname"
+}