summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2022-07-15 08:57:25 +1000
committerAndy Botting2022-07-15 08:57:25 +1000
commit3df2e59b922a6f8cd31da5e48dda5515169cb753 (patch)
tree6b3e5dbce8d0f87c64a29582b2a60b7004e1a73d
downloadaur-3df2e59b922a6f8cd31da5e48dda5515169cb753.tar.gz
Add python-aodhclient v2.4.1-1
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13e5bf15fe3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-aodhclient
+ pkgdesc = Client library for the Aodh API
+ pkgver = 2.4.1
+ pkgrel = 1
+ url = https://docs.openstack.org/python-aodhclient/
+ arch = any
+ license = Apache
+ checkdepends = python-oslotest
+ checkdepends = python-stestr
+ checkdepends = python-testtools
+ depends = python-pbr
+ depends = python-cliff
+ depends = python-osc-lib
+ depends = python-oslo-i18n
+ depends = python-oslo-serialization
+ depends = python-oslo-utils
+ depends = python-osprofiler
+ depends = python-keystoneauth1
+ depends = python-six
+ depends = python-pyparsing
+ source = https://github.com/openstack/python-aodhclient/archive/2.4.1.tar.gz
+ sha512sums = 480c098519084732f630427f9618797cf9d227497b60c759b4b2299fcfedee5d0fec35a78b581c3c8d9b2a034c7192714db3c68b1937936d2d14f6ac74f17639
+
+pkgname = python-aodhclient
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d02e6eaff6f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andy Botting <andy@andybotting.com>
+
+pkgname=python-aodhclient
+pkgver=2.4.1
+pkgrel=1
+pkgdesc='Client library for the Aodh API'
+arch=('any')
+url="https://docs.openstack.org/$pkgname/"
+license=('Apache')
+depends=('python-pbr' 'python-cliff' 'python-osc-lib' 'python-oslo-i18n'
+ 'python-oslo-serialization' 'python-oslo-utils' 'python-osprofiler'
+ 'python-keystoneauth1' 'python-six' 'python-pyparsing')
+checkdepends=('python-oslotest' 'python-stestr' 'python-testtools')
+source=("https://github.com/openstack/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('480c098519084732f630427f9618797cf9d227497b60c759b4b2299fcfedee5d0fec35a78b581c3c8d9b2a034c7192714db3c68b1937936d2d14f6ac74f17639')
+
+export PBR_VERSION=$pkgver
+
+build() {
+ cd $pkgname-$pkgver
+ # Remove functional tests as they're complicated to run
+ rm -fr aodhclient/tests/functional
+ python setup.py build
+}
+
+check() {
+ cd $pkgname-$pkgver
+ stestr run
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: