summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2019-07-22 09:06:42 -0700
committerDonald Webster2019-07-22 09:06:42 -0700
commitb0785de1818d932ef3ce7e0b3809bea45e6d2537 (patch)
treef4f800e051a2a05f54c3fb21e80258c6e941d8f7
parentcbd1c2b8d4ccfa58f80c3d9907f4d5b5c1430f2b (diff)
downloadaur-b0785de1818d932ef3ce7e0b3809bea45e6d2537.tar.gz
PKGBUILD cleanup.
-rw-r--r--PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9dcf807ea5ce..2b4a125d508a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,20 +9,13 @@ pkgdesc="Push Notifications that work with just about every platform"
arch=('any')
url="https://github.com/caronc/apprise"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools'
+ 'python2-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('e384b4670f510e6a69e91e360a7bc881bb2018d81a8196e38a218c568a98167f')
prepare() {
- cp -a apprise-$pkgver{,-py2}
-}
-
-build() {
- cd "$srcdir"/apprise-$pkgver
- python setup.py build
-
- cd "$srcdir"/apprise-$pkgver-py2
- python2 setup.py build
+ cp -a apprise-${pkgver}{,-py2}
}
package_python-apprise() {
@@ -36,8 +29,8 @@ package_python-apprise() {
'python-markdown'
'python-yaml')
- cd apprise-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ cd apprise-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-apprise() {
@@ -51,6 +44,6 @@ package_python2-apprise() {
'python2-markdown'
'python2-yaml')
- cd apprise-$pkgver-py2
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd apprise-${pkgver}-py2
+ python2 setup.py install --root="${pkgdir}" --optimize=1
}