summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2017-12-01 11:11:10 -0500
committerAdam Goldsmith2017-12-01 11:11:10 -0500
commit4f9f3436a37051391c17ded80670cda032d4878f (patch)
treed43cec81b686dc5446d012fffc64141ef59a35f2
downloadaur-python-aprs.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc0da6814838
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Dec 1 16:10:53 UTC 2017
+pkgbase = python-aprs
+ pkgdesc = A Python Module that supports connecting to APRS Interfaces, and receiving, parsing and sending APRS Frames.
+ pkgver = 7.0.0
+ pkgrel = 1
+ url = https://github.com/ampledata/aprs
+ arch = any
+ license = Apache
+ depends = python
+ depends = python-kiss
+ depends = python-requests
+ depends = python-bitarray
+ source = https://files.pythonhosted.org/packages/source/a/aprs/aprs-7.0.0.tar.gz
+ md5sums = cd4d0209fd20697bf0b0550b5032ce09
+
+pkgname = python-aprs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2e89671c53f8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.pkg.*
+/aprs-*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9be5903fbbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=python-aprs
+_pkgname=aprs
+pkgver=7.0.0
+pkgrel=1
+pkgdesc="A Python Module that supports connecting to APRS Interfaces, and receiving, parsing and sending APRS Frames."
+arch=('any')
+url="https://github.com/ampledata/aprs"
+license=('Apache')
+depends=(python python-kiss python-requests python-bitarray)
+source=("https://files.pythonhosted.org/packages/source/a/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('cd4d0209fd20697bf0b0550b5032ce09')
+
+package() {
+ cd $_pkgname-$pkgver/
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: