summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrkcf2019-07-27 10:59:14 -0500
committerrkcf2019-07-27 10:59:14 -0500
commit414132acda7f5350b76292423323ac6ec662d44b (patch)
tree9e33f8811be38dc7c29df455f411ee0e07b4e9ea
parent7a582efbe66249e372aa6724d9455614bdae8ed0 (diff)
downloadaur-414132acda7f5350b76292423323ac6ec662d44b.tar.gz
update to 2.0.15
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 772ce4b7a9fc..0def7d7c4c13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-arabic-reshaper
pkgdesc = Reconstruct Arabic sentences to be used in applications that don't support Arabic
- pkgver = 2.0.14
+ pkgver = 2.0.15
pkgrel = 3
url = https://github.com/mpcabd/python-arabic-reshaper
arch = any
- license = GPL3
+ license = MIT
makedepends = python-setuptools
makedepends = python2-setuptools
makedepends = python-future
makedepends = python2-future
makedepends = python2-configparser
- source = https://github.com/mpcabd/python-arabic-reshaper/archive/v2.0.14.tar.gz
- md5sums = 96c0bf23cbf5396f2bb8e564f4b90739
+ source = https://github.com/mpcabd/python-arabic-reshaper/archive/v2.0.15.tar.gz
+ md5sums = fadcb653c58466eb60bf8f1b4d0afd57
pkgname = python-arabic-reshaper
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 27b933be27ff..680611bfaee2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,18 @@
pkgbase=python-arabic-reshaper
pkgname=('python-arabic-reshaper' 'python2-arabic-reshaper')
-pkgver=2.0.14
+pkgver=2.0.15
pkgrel=3
pkgdesc="Reconstruct Arabic sentences to be used in applications that don't support Arabic"
makedepends=('python-setuptools' 'python2-setuptools' 'python-future' 'python2-future' 'python2-configparser')
url="https://github.com/mpcabd/python-arabic-reshaper"
-license=('GPL3')
+license=('MIT')
arch=('any')
source=("$url/archive/v$pkgver.tar.gz")
-md5sums=('96c0bf23cbf5396f2bb8e564f4b90739')
+md5sums=('fadcb653c58466eb60bf8f1b4d0afd57')
prepare() {
cp -a $pkgname-$pkgver{,-py2}
-
- # remove configparser requirement for python3
- sed -i "s/'configparser', //" $srcdir/$pkgname-$pkgver/setup.py
}
build() {
@@ -32,6 +29,7 @@ package_python-arabic-reshaper() {
provides=('python-arabic-reshaper')
cd "$srcdir/python-arabic-reshaper-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_python2-arabic-reshaper() {
@@ -39,6 +37,7 @@ package_python2-arabic-reshaper() {
provides=('python2-arabic-reshaper')
cd "$srcdir/python-arabic-reshaper-$pkgver-py2"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: