summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2019-12-12 23:43:29 +0100
committerIyán Méndez Veiga2019-12-12 23:43:29 +0100
commit0df95574235b953b4a4b4ea7581a6a2afcb77cac (patch)
tree4e09175df3fff76622a377c4f0d341e7ea1d0f15
parentafda9e5354ae56d4c0ca0b62237a6eb28f5350a2 (diff)
downloadaur-0df95574235b953b4a4b4ea7581a6a2afcb77cac.tar.gz
Add install scripts
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
-rw-r--r--python-arcgis.install11
3 files changed, 16 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fa3be2f4347..36992599ad1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-arcgis
pkgdesc = ArcGIS API for Python
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://developers.arcgis.com/python/
arch = x86_64
license = custom
@@ -12,6 +12,7 @@ pkgbase = python-arcgis
depends = python-pyshp
depends = python-matplotlib
depends = jupyter-notebook
+ depends = jupyterlab
depends = python-ipywidgets
depends = jupyter-widgetsnbextension
depends = python-keyring
diff --git a/PKGBUILD b/PKGBUILD
index d9c02d3d8b9a..a9e342998795 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=arcgis
pkgname=python-${_pkgname}
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="ArcGIS API for Python"
arch=('x86_64')
url="https://developers.arcgis.com/python/"
@@ -14,6 +14,7 @@ depends=(
'python-pyshp'
'python-matplotlib'
'jupyter-notebook'
+ 'jupyterlab'
'python-ipywidgets'
'jupyter-widgetsnbextension'
'python-keyring'
@@ -40,5 +41,5 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
- install -Dm644 "${srcdir}/LICENSE.pdf" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "${srcdir}/LICENSE.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/python-arcgis.install b/python-arcgis.install
new file mode 100644
index 000000000000..32b10451367f
--- /dev/null
+++ b/python-arcgis.install
@@ -0,0 +1,11 @@
+post_install=(
+ jupyter nbextension enable --py --sys-prefix ${_pkgname}-map-ipywidget
+)
+
+pre_upgrade=(
+ jupyter nbextension disable --py --sys-prefix ${_pkgname}-map-ipywidget
+)
+
+post_upgrade=(
+ jupyter nbextension enable --py --sys-prefix ${_pkgname}-map-ipywidget
+) \ No newline at end of file