summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-05-02 11:00:40 -0400
committerGuillaume Horel2017-05-02 11:00:40 -0400
commit8b29d7f3b94cc90c39aef98ac4d1c45cc10b7d4c (patch)
tree93db989048a666d7ce37c1654583e9a2c7417fd1
parente3f1d90fed4079e432fd40b41e9e1a883d1b2c36 (diff)
downloadaur-8b29d7f3b94cc90c39aef98ac4d1c45cc10b7d4c.tar.gz
version bump
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e82a0416366a..cb142c334fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-arch
pkgdesc = ARCH models in Python.
- pkgver = 4.0
+ pkgver = 4.1
pkgrel = 1
- url = https://pypi.python.org/pypi/arch/4.0
+ url = https://pypi.python.org/pypi/arch/4.1
arch = i686
arch = x86_64
license = custom:University of Illinois/NCSA Open Source License
+ checkdepends = python-pytest
makedepends = cython
makedepends = python-setuptools
depends = python
@@ -13,8 +14,8 @@ pkgbase = python-arch
depends = python-pandas
depends = python-scipy
depends = python-statsmodels
- source = https://github.com/bashtage/arch/archive/4.0.tar.gz
- md5sums = 9a98f2cd94fb2f8272fb5a2cad439ffc
+ source = https://github.com/bashtage/arch/archive/4.1.tar.gz
+ sha256sums = 1f3348e0eda8705671ff4041be90af230aa0a28939a5d7f3b9a2ca93cdb7c736
pkgname = python-arch
diff --git a/PKGBUILD b/PKGBUILD
index f1ca4890389e..1c04f8b6a277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-arch')
_module='arch'
-pkgver='4.0'
+pkgver='4.1'
pkgrel=1
pkgdesc="ARCH models in Python."
-url="https://pypi.python.org/pypi/arch/4.0"
+url="https://pypi.python.org/pypi/arch/4.1"
depends=('python'
'python-numpy'
'python-pandas'
'python-scipy'
'python-statsmodels')
-makedepends=(
- 'cython'
- 'python-setuptools')
+checkdepends=('python-pytest')
+makedepends=('cython' 'python-setuptools')
license=('custom:University of Illinois/NCSA Open Source License')
arch=('i686' 'x86_64')
source=("https://github.com/bashtage/arch/archive/${pkgver}.tar.gz")
-md5sums=('9a98f2cd94fb2f8272fb5a2cad439ffc')
+sha256sums=('1f3348e0eda8705671ff4041be90af230aa0a28939a5d7f3b9a2ca93cdb7c736')
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -28,3 +27,8 @@ package() {
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}
+
+check() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ py.test
+}