summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-02-19 16:37:06 -0500
committerGuillaume Horel2020-02-19 16:37:06 -0500
commitc16f33043801cf191be93844d038eafeaf0d0688 (patch)
treef4fce53e0a68d2d0a39740ad088608aba76e357e
parent0cfe3e2272ee83818de9f49cf07090b6a4c469b9 (diff)
downloadaur-c16f33043801cf191be93844d038eafeaf0d0688.tar.gz
version bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dc2a8c1d32b..3c41ec48160f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-arch
pkgdesc = ARCH models in Python.
- pkgver = 4.10.0
+ pkgver = 4.12
pkgrel = 1
url = https://pypi.python.org/pypi/arch/4.1
arch = x86_64
license = custom:University of Illinois/NCSA Open Source License
checkdepends = python-pytest
+ checkdepends = python-property-cached
checkdepends = python-seaborn
makedepends = cython
makedepends = python-setuptools
@@ -14,8 +15,8 @@ pkgbase = python-arch
depends = python-pandas
depends = python-scipy
depends = python-statsmodels
- source = python-arch-4.10.0.tar.gz::https://github.com/bashtage/arch/archive/4.10.0.tar.gz
- sha256sums = 0a24b8aca262494453557aae0c3e46e78c2c7b85db632a9e4673500a7982b7f0
+ source = python-arch-4.12.tar.gz::https://github.com/bashtage/arch/archive/4.12.tar.gz
+ sha256sums = ed6f8f70f4a1b1ce5d9fc69726e7b6ddff00c1a18acfec9b230b538b29b3211d
pkgname = python-arch
diff --git a/PKGBUILD b/PKGBUILD
index f0b885f70fd6..93832e509ceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname=('python-arch')
+pkgname='python-arch'
_module='arch'
-pkgver='4.10.0'
+pkgver='4.12'
pkgrel=1
pkgdesc="ARCH models in Python."
url="https://pypi.python.org/pypi/arch/4.1"
@@ -10,12 +10,12 @@ depends=('python'
'python-pandas'
'python-scipy'
'python-statsmodels')
-checkdepends=('python-pytest' 'python-seaborn')
+checkdepends=('python-pytest' 'python-property-cached' 'python-seaborn')
makedepends=('cython' 'python-setuptools')
license=('custom:University of Illinois/NCSA Open Source License')
arch=('x86_64')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bashtage/arch/archive/${pkgver}.tar.gz")
-sha256sums=('0a24b8aca262494453557aae0c3e46e78c2c7b85db632a9e4673500a7982b7f0')
+sha256sums=('ed6f8f70f4a1b1ce5d9fc69726e7b6ddff00c1a18acfec9b230b538b29b3211d')
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -30,5 +30,5 @@ package() {
check() {
cd "${srcdir}/${_module}-${pkgver}"
- PYTHONPATH=.. py.test arch
+ PYTHONPATH=.. py.test arch/tests
}