summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-01-10 14:43:57 -0500
committerGuillaume Horel2017-01-10 14:43:57 -0500
commitc1fe5b98fd34696716e195061bab6e3e36093825 (patch)
tree5cd304d0b23315f10484569f65ed814b2cdcac83
downloadaur-c1fe5b98fd34696716e195061bab6e3e36093825.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a85433072f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-arch
+ pkgdesc = ARCH models in Python.
+ pkgver = 4.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/arch/4.0
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-scipy
+ depends = python-statsmodels
+ source = https://github.com/bashtage/arch/archive/4.0.tar.gz
+ md5sums = 9a98f2cd94fb2f8272fb5a2cad439ffc
+
+pkgname = python-arch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5a27f754009
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=('python-arch')
+_module='arch'
+pkgver='4.0'
+pkgrel=1
+pkgdesc="ARCH models in Python."
+url="https://pypi.python.org/pypi/arch/4.0"
+depends=('python'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-scipy'
+ 'python-statsmodels')
+makedepends=(
+ 'cython'
+ 'python-setuptools')
+license=('BSD')
+arch=('i686' 'x86_64')
+source=("https://github.com/bashtage/arch/archive/${pkgver}.tar.gz")
+md5sums=('9a98f2cd94fb2f8272fb5a2cad439ffc')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}