summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2023-05-05 15:05:58 -0400
committerGuillaume Horel2023-05-05 15:05:58 -0400
commitf1a71698bd8f098863ef58b5109ef6033b391b86 (patch)
tree76543dfff7b6df0910d495eef3baa504a613695f
parent5e691de719fcf8b0fb7137d41feb75286845200b (diff)
downloadaur-f1a71698bd8f098863ef58b5109ef6033b391b86.tar.gz
fix tests
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dcbc1017c75..4e573d07e1b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,11 @@ pkgbase = python-arch
url = https://pypi.python.org/pypi/arch
arch = x86_64
license = custom:University of Illinois/NCSA Open Source License
+ checkdepends = python-jupyter-client
checkdepends = python-pytest
+ checkdepends = python-matplotlib
+ checkdepends = python-nbconvert
+ checkdepends = python-nbformat
checkdepends = python-property-cached
checkdepends = python-seaborn
makedepends = cython
diff --git a/PKGBUILD b/PKGBUILD
index f60bdaba9df9..6fbd46e834cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ depends=('python-numpy'
'python-pandas'
'python-scipy'
'python-statsmodels')
-checkdepends=('python-pytest' 'python-property-cached' 'python-seaborn')
+checkdepends=('python-jupyter-client' 'python-pytest' 'python-matplotlib' 'python-nbconvert' 'python-nbformat' 'python-property-cached' 'python-seaborn')
makedepends=('cython' 'python-setuptools')
license=('custom:University of Illinois/NCSA Open Source License')
arch=('x86_64')
@@ -30,5 +30,5 @@ package() {
check() {
cd "${_module}-${pkgver}"
python setup.py build_ext --inplace
- PYTHONPATH=. pytest arch/tests
+ PYTHONPATH=$(pwd) pytest arch/tests
}