summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuche12021-12-22 00:08:16 +0200
committerkuche12021-12-22 00:08:16 +0200
commitcc47e60d33dccf12c9b20825da93f9be6a5cdafe (patch)
treeb261aef2aaf10c12034e755fea418248eb82d007
downloadaur-cc47e60d33dccf12c9b20825da93f9be6a5cdafe.tar.gz
fc
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3d0fb4d2f92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-argostranslate-git
+ pkgdesc = Open source neural machine translation in Python. Designed to be used either as a Python library or desktop application. Uses OpenNMT for translations and PyQt for GUI.
+ pkgver = r434.c97f52519d8d55524bee092ed2bd0cde7d542f68
+ pkgrel = 1
+ url = https://github.com/argosopentech/argos-translate/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-argostranslate
+ source = git+https://github.com/argosopentech/argos-translate/
+ sha256sums = SKIP
+
+pkgname = python-argostranslate-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b66ae6889d57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+pkgname=python-argostranslate-git
+pkgver=r434.c97f52519d8d55524bee092ed2bd0cde7d542f68
+pkgrel=1
+pkgdesc=" Open source neural machine translation in Python. Designed to be used either as a Python library or desktop application. Uses OpenNMT for translations and PyQt for GUI."
+arch=('any')
+url="https://github.com/argosopentech/argos-translate/"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+provides=("python-argostranslate")
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/argos-translate
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse HEAD)"
+}
+
+check() {
+ cd $srcdir/argos-translate
+ python3 setup.py check
+}
+
+package() {
+ cd $srcdir/argos-translate
+ python setup.py install --root="$pkgdir/" --optimize=1
+}