summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-01-12 10:12:51 -0500
committerCarlos Aznarán2024-01-12 10:12:51 -0500
commitd1e0a1d1aec70fc63da3f78140733ab78673defb (patch)
treeac8f7bef103002ed155eb62c301e4fe9d455733a
downloadaur-d1e0a1d1aec70fc63da3f78140733ab78673defb.tar.gz
Bump version to 0.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD35
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7812e04391cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-arm-preprocessing
+ pkgdesc = Implementation of several preprocessing techniques for Association Rule Mining
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/firefly-cpp/arm-preprocessing
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry-core
+ depends = python-niaarm
+ depends = python-scikit-learn
+ source = arm-preprocessing-0.1.0.tar.gz::https://github.com/firefly-cpp/arm-preprocessing/archive/0.1.0.tar.gz
+ sha512sums = 5162f8fb6478e320d68a75f470f0e4970d7177dec421ef55b76eae06bda3cfaf8a6caf9c19d493e5416c8a9208552a03becb142a5ad36900aad1b7ce5290f48c
+
+pkgname = python-arm-preprocessing
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5693b52857d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=arm-preprocessing
+pkgname=python-${_base}
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Implementation of several preprocessing techniques for Association Rule Mining"
+url="https://github.com/firefly-cpp/${_base}"
+arch=(any)
+license=(MIT)
+depends=(python-niaarm python-scikit-learn)
+makedepends=(python-build python-installer python-poetry-core)
+checkdepends=(python-pytest)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('5162f8fb6478e320d68a75f470f0e4970d7177dec421ef55b76eae06bda3cfaf8a6caf9c19d493e5416c8a9208552a03becb142a5ad36900aad1b7ce5290f48c')
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m pytest
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base/-/_}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}