summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-01-02 15:18:12 +0100
committerPhilipp A2019-01-02 15:18:12 +0100
commit80770a642d3935e4d515bdcbd9603587fc0bb00a (patch)
treeeaca924f68232034e0a92bb3fe47e6c2b338be6c
downloadaur-80770a642d3935e4d515bdcbd9603587fc0bb00a.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd8c0e8e593b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-asciitree
+ pkgdesc = Draws +-- ASCII Trees.
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = http://github.com/mbr/asciitree
+ arch = any
+ license = MIT
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/a/asciitree/asciitree-0.3.3.tar.gz
+ sha256sums = 4aa4b9b649f85e3fcb343363d97564aa1fb62e249677f2e18a96765145cc0f6e
+
+pkgname = python-asciitree
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8bba9d8c732d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.tar.gz
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..271141a03ae7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+_name=asciitree
+pkgname=python-asciitree
+pkgver=0.3.3
+pkgrel=1
+pkgdesc='Draws +-- ASCII Trees.'
+arch=(any)
+url='http://github.com/mbr/asciitree'
+license=(MIT)
+depends=(python)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('4aa4b9b649f85e3fcb343363d97564aa1fb62e249677f2e18a96765145cc0f6e')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 || return 1
+}