summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2022-05-24 09:27:28 +0800
committerPumpkinCheshire2022-05-24 09:27:28 +0800
commitc343c472b9b39bef1de51acd5066d5c82dcc67a0 (patch)
tree86462ac9f52b7fed585f146ed0050c62abc6ea12
parent184982c720d9b17613478a7e3da2dfe1b91b927b (diff)
downloadaur-python-asks.tar.gz
bump to 3.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 35 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4fb1f9a916f..ba99d81db958 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = python-asks
pkgdesc = Async requests-like httplib for python.
- pkgver = 2.4.12
- pkgrel = 2
+ pkgver = 3.0.0
+ pkgrel = 1
url = https://github.com/theelous3/asks
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
depends = python-async_generator
depends = python-h11
depends = python-anyio
@@ -13,8 +15,7 @@ pkgbase = python-asks
optdepends = python-curio: test use
optdepends = python-pytest: test use
optdepends = python-overly: test use
- source = https://files.pythonhosted.org/packages/source/a/asks/asks-2.4.12.tar.gz
- sha256sums = 38de944eb350e7e4e3a918055fa8ff033da5f7b5ff385c1160a2d6b9d84783b0
+ source = https://files.pythonhosted.org/packages/source/a/asks/asks-3.0.0.tar.gz
+ b2sums = 34202ba49b23dec5161f8b39a2dc970b4caf83b31aeaa5b9e93f57b05ec48a47a953395fbb79c1e114fef17ef58ee184c0240292b0209de0f70e39014ebc21ad
pkgname = python-asks
-
diff --git a/PKGBUILD b/PKGBUILD
index eda50afd5b7a..61dcb3c69692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,42 @@
-# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+#!/bin/bash
+
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
_name=asks
pkgname=python-asks
-pkgver=2.4.12
-pkgrel=2
+pkgver=3.0.0
+pkgrel=1
pkgdesc="Async requests-like httplib for python."
arch=('any')
url="https://github.com/theelous3/asks"
license=('MIT')
-depends=('python-async_generator' 'python-h11' 'python-anyio')
-optdepends=('python-trio: test use' 'python-curio: test use' 'python-pytest: test use' 'python-overly: test use')
-makedepends=('python-setuptools')
+depends=(
+ 'python-async_generator'
+ 'python-h11'
+ 'python-anyio')
+optdepends=(
+ 'python-trio: test use'
+ 'python-curio: test use'
+ 'python-pytest: test use'
+ 'python-overly: test use')
+makedepends=(
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('38de944eb350e7e4e3a918055fa8ff033da5f7b5ff385c1160a2d6b9d84783b0')
+b2sums=('34202ba49b23dec5161f8b39a2dc970b4caf83b31aeaa5b9e93f57b05ec48a47a953395fbb79c1e114fef17ef58ee184c0240292b0209de0f70e39014ebc21ad')
build() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py build
+ cd "$srcdir/$_name-$pkgver" || exit
+
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENCE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$srcdir/$_name-$pkgver" || exit
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ # install -Dm644 LICENCE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
}