summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-03 23:02:19 +1100
committerPumpkinCheshire2020-11-03 23:02:19 +1100
commit198146828f3a56b8dfa87b163f64b2b624087ca4 (patch)
treef923e060d3675e49819f5d9e69698b36a4e7e81a
parent407a23f91ff2c3ce4333be99bb493a36da6150e0 (diff)
downloadaur-198146828f3a56b8dfa87b163f64b2b624087ca4.tar.gz
upgrade to 2.4.12
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72e241c302d3..328bac3f10c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python-asks
- pkgdesc = asks - async http
- pkgver = 2.2.0
+ pkgdesc = Async requests-like httplib for python.
+ pkgver = 2.4.12
pkgrel = 1
url = https://github.com/theelous3/asks
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
- depends = python-multio
+ depends = python-async_generator
depends = python-h11
- source = https://files.pythonhosted.org/packages/56/c5/046c4d7d863d2a453698af7220803127750140c80fb8f8b4233b0501681b/asks-2.2.0.tar.gz
- md5sums = a1709dd181ebc602a72b2a2d9b88971d
+ depends = python-anyio
+ optdepends = python-trio: test use
+ optdepends = python-curio: test use
+ optdepends = python-pytest: test use
+ optdepends = python-overly: test use
+ source = https://files.pythonhosted.org/packages/source/a/asks/asks-2.4.12.tar.gz
+ sha256sums = 38de944eb350e7e4e3a918055fa8ff033da5f7b5ff385c1160a2d6b9d84783b0
pkgname = python-asks
diff --git a/PKGBUILD b/PKGBUILD
index 5831937ee0f1..900de812b871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
-_pkgname=asks
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+
+_name=asks
pkgname=python-asks
-pkgver=2.2.0
+pkgver=2.4.12
pkgrel=1
-pkgdesc="asks - async http"
+pkgdesc="Async requests-like httplib for python."
arch=('any')
url="https://github.com/theelous3/asks"
license=('MIT')
-depends=('python' 'python-multio' 'python-h11')
+depends=('python-async_generator' 'python-h11' 'python-anyio')
+optdepends=('python-trio: test use' 'python-curio: test use' 'python-pytest: test use' 'python-overly: test use')
makedepends=('python-setuptools')
-source=('https://files.pythonhosted.org/packages/56/c5/046c4d7d863d2a453698af7220803127750140c80fb8f8b4233b0501681b/asks-2.2.0.tar.gz')
-md5sums=('a1709dd181ebc602a72b2a2d9b88971d')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('38de944eb350e7e4e3a918055fa8ff033da5f7b5ff385c1160a2d6b9d84783b0')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py build
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENCE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set sw=2 et: