summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Debucquoy2024-05-27 11:50:34 +0200
committerAnthony Debucquoy2024-05-27 11:50:34 +0200
commit5250028596f9ef74e963af69ffe5460a52d5d78d (patch)
treec763dd8de8a32d25d114bda228f60dacdf702969
downloadaur-5250028596f9ef74e963af69ffe5460a52d5d78d.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c3e04d0ace5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-asphalt
+ pkgver = 4.12.0
+ pkgrel = 0
+ url = https://github.com/asphalt-framework/asphalt
+ arch = any
+ license = Apache-2.0
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/a/asphalt/asphalt-4.12.0.tar.gz
+ sha256sums = 21e2b323aba833ecd1ea84746b55d486de5027f119987528ddb7b20c0272d10e
+
+pkgname = python-asphalt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6923a319c9b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Debucquoy Anthony (tonitch) <d.tonitch@gmail.com>
+
+pkgname=python-asphalt
+_name=${pkgname#python-}
+pkgver=4.12.0
+pkgrel=0
+url="https://github.com/asphalt-framework/asphalt"
+license=('Apache-2.0')
+arch=('any')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+}
+
+sha256sums=('21e2b323aba833ecd1ea84746b55d486de5027f119987528ddb7b20c0272d10e')
+