summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-01-09 19:15:38 +0100
committerMichel Zou2019-01-09 19:15:38 +0100
commit1acc02b5159b845d2a28c8be40048e51e556bdda (patch)
tree29c76d12f6d018a0f3cee7623229d8d470062abe
parent1f99b8cd98e043df5d95780a89b72c49ddb8444c (diff)
downloadaur-1acc02b5159b845d2a28c8be40048e51e556bdda.tar.gz
glimda
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 720b0ac94a3b..e2edf4e1bcc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,11 +13,10 @@ pkgbase = python-assimulo
makedepends = gcc-fortran
makedepends = sundials
makedepends = lapack
- makedepends = subversion
- source = svn+https://svn.jmodelica.org/assimulo/tags/Assimulo-3.0
+ source = https://github.com/modelon/Assimulo/archive/Assimulo-3.0.tar.gz
source = sundials4.patch
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = python-assimulo
depends = python-scipy
diff --git a/PKGBUILD b/PKGBUILD
index 5b0c6baca9d6..d1fea2d41074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,33 +6,34 @@ pkgdesc="A package for solving ordinary differential equations and differential
url="http://www.jmodelica.org/assimulo"
arch=('i686' 'x86_64')
license=('LGPL')
-makedepends=('python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'gcc-fortran' 'sundials' 'lapack' 'subversion')
-# PyPI archive is missing .pyf files
-# source=("https://pypi.io/packages/source/A/Assimulo/Assimulo-${pkgver}.tar.gz")
-source=("svn+https://svn.jmodelica.org/assimulo/tags/Assimulo-${pkgver}" sundials4.patch)
-md5sums=('SKIP' SKIP )
+makedepends=('python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'gcc-fortran' 'sundials' 'lapack')
+source=("https://github.com/modelon/Assimulo/archive/Assimulo-${pkgver}.tar.gz" sundials4.patch)
+sha256sums=('SKIP' SKIP )
prepare() {
- cd "${srcdir}"/Assimulo-$pkgver
+ cd "${srcdir}"/Assimulo-Assimulo-$pkgver
# try to build with sundials 4.0
patch -p0 -i "${srcdir}"/sundials4.patch
+
+ # use shared lib
+ sed -i "s|BLASname_t+'.a'|BLASname_t+'.so'|g" setup.py
}
build() {
- cp -r "${srcdir}"/Assimulo-$pkgver "${srcdir}"/Assimulo-$pkgver-py2
+ cp -r "${srcdir}"/Assimulo-Assimulo-$pkgver "${srcdir}"/Assimulo-Assimulo-$pkgver-py2
}
package_python-assimulo() {
depends=('python-scipy' 'python-matplotlib' 'lapack' 'sundials')
- cd "${srcdir}/Assimulo-$pkgver"
- python setup.py install --root=${pkgdir} --optimize=1 --extra-fortran-link-flags="-shared" --sundials-home=/usr
+ cd "${srcdir}/Assimulo-Assimulo-$pkgver"
+ python setup.py install --root=${pkgdir} --optimize=1 --extra-fortran-link-flags="-shared" --sundials-home=/usr --blas-home=/usr/lib --blas-name="blas" --lapack-home=/usr
}
package_python2-assimulo() {
depends=('python2-numpy' 'python2-matplotlib' 'lapack' 'sundials')
- cd "${srcdir}/Assimulo-$pkgver-py2"
- python2 setup.py install --root=${pkgdir} --optimize=1 --extra-fortran-link-flags="-shared" --sundials-home=/usr
+ cd "${srcdir}/Assimulo-Assimulo-$pkgver-py2"
+ python2 setup.py install --root=${pkgdir} --optimize=1 --extra-fortran-link-flags="-shared" --sundials-home=/usr --blas-home=/usr/lib --blas-name="blas" --lapack-home=/usr
}