summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-01-08 20:30:55 +0100
committerMichel Zou2019-01-08 20:30:55 +0100
commit1f99b8cd98e043df5d95780a89b72c49ddb8444c (patch)
tree4fb60f2d958dc47528d25539b8185aaf8523d21d
parent4a75591f31b4d04c24e2d23ff276ef1bdd3338b2 (diff)
downloadaur-1f99b8cd98e043df5d95780a89b72c49ddb8444c.tar.gz
lsundials_kinsol
-rw-r--r--sundials4.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/sundials4.patch b/sundials4.patch
index 05a302cadae8..2728d2a230dc 100644
--- a/sundials4.patch
+++ b/sundials4.patch
@@ -1,3 +1,16 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 875)
++++ setup.py (working copy)
+@@ -426,7 +426,7 @@
+ ext_list[-1].library_dirs = [self.libdirs]
+
+ if self.SUNDIALS_version >= (3,0,0):
+- ext_list[-1].libraries = ["sundials_cvodes", "sundials_nvecserial", "sundials_idas", "sundials_sunlinsoldense", "sundials_sunlinsolspgmr", "sundials_sunmatrixdense", "sundials_sunmatrixsparse"]
++ ext_list[-1].libraries = ["sundials_cvodes", "sundials_nvecserial", "sundials_idas", "sundials_sunlinsoldense", "sundials_sunlinsolspgmr", "sundials_sunmatrixdense", "sundials_sunmatrixsparse", "sundials_kinsol"]
+ else:
+ ext_list[-1].libraries = ["sundials_cvodes", "sundials_nvecserial", "sundials_idas"]
+ if self.sundials_with_superlu and self.with_SLU: #If SUNDIALS is compiled with support for SuperLU
Index: src/lib/sundials_includes.pxd
===================================================================
--- src/lib/sundials_includes.pxd (revision 875)