summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-01-09 19:36:13 +0100
committerMichel Zou2019-01-09 19:36:13 +0100
commit3180abeea4b442dd79ef2f35edb0a8835bda2f4c (patch)
tree43299fcb2fa8579a850a429714f82f03487bdfa8
parent1acc02b5159b845d2a28c8be40048e51e556bdda (diff)
downloadaur-3180abeea4b442dd79ef2f35edb0a8835bda2f4c.tar.gz
kinsol
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--sundials4.patch9
3 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2edf4e1bcc0..f497b99ba1cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,7 @@ pkgbase = python-assimulo
makedepends = lapack
source = https://github.com/modelon/Assimulo/archive/Assimulo-3.0.tar.gz
source = sundials4.patch
- sha256sums = SKIP
+ sha256sums = 6a1437af8ea0c9af3c0afa1efb44f5d1e11edfec1250ce3510f9e33397a04e6b
sha256sums = SKIP
pkgname = python-assimulo
diff --git a/PKGBUILD b/PKGBUILD
index d1fea2d41074..8e89bedf69a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@ arch=('i686' 'x86_64')
license=('LGPL')
makedepends=('python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'gcc-fortran' 'sundials' 'lapack')
source=("https://github.com/modelon/Assimulo/archive/Assimulo-${pkgver}.tar.gz" sundials4.patch)
-sha256sums=('SKIP' SKIP )
+sha256sums=('6a1437af8ea0c9af3c0afa1efb44f5d1e11edfec1250ce3510f9e33397a04e6b'
+ 'SKIP')
prepare() {
cd "${srcdir}"/Assimulo-Assimulo-$pkgver
diff --git a/sundials4.patch b/sundials4.patch
index 2728d2a230dc..754bde37026f 100644
--- a/sundials4.patch
+++ b/sundials4.patch
@@ -11,6 +11,15 @@ Index: setup.py
else:
ext_list[-1].libraries = ["sundials_cvodes", "sundials_nvecserial", "sundials_idas"]
if self.sundials_with_superlu and self.with_SLU: #If SUNDIALS is compiled with support for SuperLU
+@@ -444,7 +444,7 @@
+ compile_time_env=compile_time_env, force=True)
+ ext_list[-1].include_dirs = [np.get_include(), "assimulo","assimulo"+os.sep+"lib", self.incdirs]
+ ext_list[-1].library_dirs = [self.libdirs]
+- ext_list[-1].libraries = ["sundials_kinsol", "sundials_nvecserial"]
++ ext_list[-1].libraries = ["sundials_kinsol", "sundials_nvecserial", "sundials_cvodes", "sundials_idas"]
+
+ if self.sundials_with_superlu and self.with_SLU: #If SUNDIALS is compiled with support for SuperLU
+ ext_list[-1].include_dirs.append(self.SLUincdir)
Index: src/lib/sundials_includes.pxd
===================================================================
--- src/lib/sundials_includes.pxd (revision 875)