summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2024-03-13 07:29:37 +0100
committerMichel Zou2024-03-13 07:29:37 +0100
commit563ce1f3a59f2a95dec13f85e7859233f2211cb6 (patch)
tree38e065f54148c321cc3c66da41d08e7469d9d8ee
parent7fe157ab637f61360cf4069bb50433ec598abbcc (diff)
downloadaur-563ce1f3a59f2a95dec13f85e7859233f2211cb6.tar.gz
v7
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4da0c64c5640..d4a923dc0326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,14 @@ arch=('x86_64')
license=('LGPL')
makedepends=('python-setuptools' 'cython0' 'gcc-fortran')
depends=('python-scipy' 'python-matplotlib' 'lapack' 'sundials')
-source=("https://github.com/modelon-community/Assimulo/archive/Assimulo-${pkgver}.tar.gz")
-sha256sums=('1f4d6fdde384c36bc8297e639cc5ece98817e6bbbe7e54e21ed20b1ff8f6fe7f')
+source=("https://github.com/modelon-community/Assimulo/archive/Assimulo-${pkgver}.tar.gz" sundials6.patch)
+sha256sums=('1f4d6fdde384c36bc8297e639cc5ece98817e6bbbe7e54e21ed20b1ff8f6fe7f' SKIP)
prepare() {
cd "${srcdir}"/Assimulo-Assimulo-$pkgver
+ patch -p1 -i "${srcdir}"/sundials6.patch
+
# use shared lib
sed -i "s|BLASname_t+'.a'|BLASname_t+'.so'|g" setup.py
}