summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-03-19 21:06:14 +0100
committerMichel Zou2019-03-19 21:06:14 +0100
commitdde1cdad235d715ef5769f51359edc64445fd266 (patch)
tree8bd43d0169d170606776ed62ecd31083e750b7e8
parent3180abeea4b442dd79ef2f35edb0a8835bda2f4c (diff)
downloadaur-dde1cdad235d715ef5769f51359edc64445fd266.tar.gz
drop python2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f497b99ba1cf..fceee13efd0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,12 +7,14 @@ pkgbase = python-assimulo
arch = x86_64
license = LGPL
makedepends = python-setuptools
- makedepends = python2-setuptools
makedepends = cython
- makedepends = cython2
makedepends = gcc-fortran
makedepends = sundials
makedepends = lapack
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = lapack
+ depends = sundials
source = https://github.com/modelon/Assimulo/archive/Assimulo-3.0.tar.gz
source = sundials4.patch
sha256sums = 6a1437af8ea0c9af3c0afa1efb44f5d1e11edfec1250ce3510f9e33397a04e6b
@@ -24,9 +26,3 @@ pkgname = python-assimulo
depends = lapack
depends = sundials
-pkgname = python2-assimulo
- depends = python2-numpy
- depends = python2-matplotlib
- depends = lapack
- depends = sundials
-
diff --git a/PKGBUILD b/PKGBUILD
index 8e89bedf69a3..f7ee34f85b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-pkgbase=python-assimulo
-pkgname=('python-assimulo' 'python2-assimulo')
+pkgname=python-assimulo
pkgver=3.0
pkgrel=1
pkgdesc="A package for solving ordinary differential equations and differential algebraic equations"
url="http://www.jmodelica.org/assimulo"
arch=('i686' 'x86_64')
license=('LGPL')
-makedepends=('python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'gcc-fortran' 'sundials' 'lapack')
+makedepends=('python-setuptools' 'cython' 'gcc-fortran' 'sundials' 'lapack')
+depends=('python-scipy' 'python-matplotlib' 'lapack' 'sundials')
source=("https://github.com/modelon/Assimulo/archive/Assimulo-${pkgver}.tar.gz" sundials4.patch)
sha256sums=('6a1437af8ea0c9af3c0afa1efb44f5d1e11edfec1250ce3510f9e33397a04e6b'
'SKIP')
@@ -25,16 +25,10 @@ build() {
cp -r "${srcdir}"/Assimulo-Assimulo-$pkgver "${srcdir}"/Assimulo-Assimulo-$pkgver-py2
}
-package_python-assimulo() {
+package() {
depends=('python-scipy' 'python-matplotlib' 'lapack' 'sundials')
cd "${srcdir}/Assimulo-Assimulo-$pkgver"
python setup.py install --root=${pkgdir} --optimize=1 --extra-fortran-link-flags="-shared" --sundials-home=/usr --blas-home=/usr/lib --blas-name="blas" --lapack-home=/usr
}
-package_python2-assimulo() {
- depends=('python2-numpy' 'python2-matplotlib' 'lapack' 'sundials')
-
- cd "${srcdir}/Assimulo-Assimulo-$pkgver-py2"
- python2 setup.py install --root=${pkgdir} --optimize=1 --extra-fortran-link-flags="-shared" --sundials-home=/usr --blas-home=/usr/lib --blas-name="blas" --lapack-home=/usr
-}