summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2023-08-23 15:29:49 +0200
committerMatheus2023-08-23 15:29:49 +0200
commit1dbeb0a668d71e122d0274fcdbec0103e5306866 (patch)
tree10e5b7295f0164bb36a425b13e56ba24bff2d316
parent458535cf9af38655c47a90d0d048ebc77617418e (diff)
downloadaur-1dbeb0a668d71e122d0274fcdbec0103e5306866.tar.gz
Error fixed.
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5161fb4e8443..67c92ff009e9 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = python-ast-comments
checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
- makedepends = python-poetry
+ makedepends = python-poetry-core
depends = python
source = python-ast-comments-v1.1.0.tar.gz::https://github.com/t3rn0/ast-comments/archive/refs/tags/1.1.0.tar.gz
sha512sums = 92e09434a560fcf8d3f626587ae3fab43d179cf71c8ec9c885495857fa1c85f666ae9006a8ed5a2b053a18d12b0a967e6142bf27b24af977f97b68080fc62567
diff --git a/PKGBUILD b/PKGBUILD
index a91629dd9ae6..c56479b12c19 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ arch=("any")
url="https://github.com/t3rn0/${_pkgname}"
license=("MIT")
depends=("python")
-makedepends=("python-build" "python-installer" "python-poetry")
+makedepends=("python-build" "python-installer" "python-poetry-core")
checkdepends=("python-pytest")
source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
sha512sums=("92e09434a560fcf8d3f626587ae3fab43d179cf71c8ec9c885495857fa1c85f666ae9006a8ed5a2b053a18d12b0a967e6142bf27b24af977f97b68080fc62567")
@@ -23,7 +23,8 @@ sha512sums=("92e09434a560fcf8d3f626587ae3fab43d179cf71c8ec9c885495857fa1c85f666a
build()
{
cd "${srcdir}"/"${_pkgname}"-"${pkgver}"/ || exit 1
- python -m build -nw
+ # -n cannot be used as Python files will be missing.
+ python -m build -w
}
check()