summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Cassani2019-06-06 11:53:19 +0200
committerFederico Cassani2019-06-06 11:54:41 +0200
commit9d1deec2c4177ad7ba2d7950719d99ce592c219c (patch)
tree92fb92b81930e3bb8b0bc5dd979fe7bac11e661d
downloadaur-9d1deec2c4177ad7ba2d7950719d99ce592c219c.tar.gz
INIT version 1.9.8
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD24
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b4501f5a435
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-astetik
+ pkgdesc = Astetik provides a very high level overlay on Seaborn and matplotlib. It is a data visualization library for data exploration, and for telling captivating stories with data.
+ pkgver = 1.9.8
+ pkgrel = 1
+ url = https://github.com/autonomio/astetik
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-statsmodels
+ depends = python-scikit-learn
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-wrangle
+ depends = python-seaborn
+ depends = python-patsy
+ depends = python-geonamescache
+ depends = ipython
+ source = https://files.pythonhosted.org/packages/03/c7/d074a03a59f55708cacb875c008bf375028c452a1ffcc452762a3c3dfed2/astetik-1.9.8.tar.gz
+ sha256sums = bcc4baba5d3a909e3ee91d109993b752cae7829c2c174f8f2c6d07d33ae4c47b
+
+pkgname = python-astetik
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b4a8512010
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afb2a7080a5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Federico Cassani <federico dot cassani at outlook dot com>
+
+pkgname="python-astetik"
+_pkgname="astetik"
+pkgver=1.9.8
+pkgrel=1
+pkgdesc="Astetik provides a very high level overlay on Seaborn and matplotlib. It is a data visualization library for data exploration, and for telling captivating stories with data."
+arch=('any')
+url="https://github.com/autonomio/astetik"
+license=('MIT')
+depends=('python' 'python-statsmodels' 'python-scikit-learn' 'python-numpy' 'python-pandas' 'python-wrangle' 'python-seaborn' 'python-patsy' 'python-geonamescache' 'ipython')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/03/c7/d074a03a59f55708cacb875c008bf375028c452a1ffcc452762a3c3dfed2/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('bcc4baba5d3a909e3ee91d109993b752cae7829c2c174f8f2c6d07d33ae4c47b')
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}