summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEkin Dursun2018-06-13 22:44:00 +0300
committerEkin Dursun2018-06-13 22:44:00 +0300
commit2079a6987d1efab7622039e5683a75e798299f9f (patch)
tree386063c090a891708ffc9c116b087757e2aa07e9
parent8a1b8532d2a4370925e879eaf9c60dc46bbed307 (diff)
downloadaur-2079a6987d1efab7622039e5683a75e798299f9f.tar.gz
Version bump
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 32 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 847b6f18ee52..c0875411ef38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = python-astral
pkgdesc = Calculations for the position of the sun and moon.
- pkgver = 1.6
- pkgrel = 0
+ pkgver = 1.6.1
+ pkgrel = 1
url = https://github.com/sffjunkie/astral
arch = any
- license = unknown
+ license = Apache
makedepends = python-setuptools
- depends = python
- depends = python-pytz
- source = https://files.pythonhosted.org/packages/52/10/e9fbc6f7c9f8cc411003a3fd3e3df75de79447a8b965ae96272d526fba28/astral-1.6.tar.gz
- sha256sums = 874b397ddbf0a4c1d8d644b21c2481e8a96b61343f820ad52d8a322d61a15083
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/a/astral/astral-1.6.1.tar.gz
+ sha256sums = ab0c08f2467d35fcaeb7bad15274743d3ac1ad18b5391f64a0058a9cd192d37d
pkgname = python-astral
- depends = python
+ depends = python-requests
depends = python-pytz
+pkgname = python2-astral
+ depends = python2-requests
+ depends = python2-pytz
+
diff --git a/PKGBUILD b/PKGBUILD
index a2215306286c..4f01ec0b937f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: Gregoire Seux <grego_aur@familleseux.net>
+# Maintainer: Ekin Dursun <ekindursun@gmail.com>
+# Contributor: Gregoire Seux <grego_aur@familleseux.net>
-pkgbase=('python-astral')
-pkgname=('python-astral')
-_module='astral'
-pkgver='1.6'
-pkgrel=0
+pkgbase='python-astral'
+pkgname=('python-astral' 'python2-astral')
+_name='astral'
+pkgver=1.6.1
+pkgrel=1
pkgdesc="Calculations for the position of the sun and moon."
url="https://github.com/sffjunkie/astral"
-depends=('python' 'python-pytz')
-makedepends=('python-setuptools')
-license=('unknown')
+makedepends=('python-setuptools' 'python2-setuptools')
+license=('Apache')
arch=('any')
-source=("https://files.pythonhosted.org/packages/52/10/e9fbc6f7c9f8cc411003a3fd3e3df75de79447a8b965ae96272d526fba28/astral-${pkgver}.tar.gz")
-sha256sums=('874b397ddbf0a4c1d8d644b21c2481e8a96b61343f820ad52d8a322d61a15083')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('ab0c08f2467d35fcaeb7bad15274743d3ac1ad18b5391f64a0058a9cd192d37d')
-build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+package_python-astral() {
+ depends=('python-requests' 'python-pytz')
+
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}
-package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+package_python2-astral() {
+ depends=('python2-requests' 'python2-pytz')
+
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
}