summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrégoire Seux2017-05-22 18:42:24 +0200
committerGrégoire Seux2017-05-22 18:42:24 +0200
commitd34b24b7cb4405aa0463a1b12083a5dc319cc0be (patch)
tree64c01871df4fd4a84c765e598a36c8be9ade48dc
downloadaur-d34b24b7cb4405aa0463a1b12083a5dc319cc0be.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0161a2b8c091
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-astral
+ pkgdesc = Calculations for the position of the sun and moon.
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/sffjunkie/astral
+ arch = any
+ license = unknown
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/a4/d6/c309f266677372964c6002a56a7bec2a90875338a71325e20b24d6d1e187/astral-1.4.zip
+ md5sums = 140499d213a234cb216e6b7fe36ee3c7
+
+pkgname = python-astral
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0753df2c93a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gregoire Seux <grego_aur@familleseux.net>
+
+pkgbase=('python-astral')
+pkgname=('python-astral')
+_module='astral'
+pkgver='1.4'
+pkgrel=1
+pkgdesc="Calculations for the position of the sun and moon."
+url="https://github.com/sffjunkie/astral"
+depends=('python')
+makedepends=('python-setuptools')
+license=('unknown')
+arch=('any')
+source=("https://pypi.python.org/packages/a4/d6/c309f266677372964c6002a56a7bec2a90875338a71325e20b24d6d1e187/astral-${pkgver}.zip")
+md5sums=('140499d213a234cb216e6b7fe36ee3c7')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}