summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-19 13:13:27 -0500
committerLuis Martinez2021-09-19 13:13:27 -0500
commitd4e9620ea44fc40ccbabdbebdb4d6ff7f77ebe00 (patch)
treeda2eb0a671dbb389dd451080a955b18ac576474b
parent2c5632a858da7b4501d2060df7c93dc3a35741dc (diff)
downloadaur-d4e9620ea44fc40ccbabdbebdb4d6ff7f77ebe00.tar.gz
update to 1.0.0
-rw-r--r--.SRCINFO29
-rw-r--r--001-setup.cfg.patch15
-rw-r--r--PKGBUILD48
3 files changed, 68 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41dd77a8ce77..c1254cb3bd82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,24 @@
pkgbase = python-astroml
- pkgdesc = AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib.
- pkgver = 0.3
+ pkgdesc = Machine learning, statistics, and data mining for astronomy and astrophysics
+ pkgver = 1.0
pkgrel = 1
- url = http://www.astroml.org/
+ url = https://www.astroml.org
arch = any
- license = BSD-3-Clause
- depends = python-numpy
- depends = python-scipy
- depends = python-scikit-learn
- depends = python-matplotlib
+ license = BSD
+ checkdepends = python-pytest-runner
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python>=3.5
+ depends = python-astropy>=3.0
+ depends = python-matplotlib>=3.0
+ depends = python-numpy>=1.13
+ depends = python-scipy>=0.18
+ depends = python-scikit-learn>=0.18
optdepends = astroml-examples
- source = https://pypi.python.org/packages/source/a/astroML/astroML-0.3.tar.gz
- md5sums = 56d5c281ca079eb569ef1898be1604db
+ source = python-astroml-1.0::git+https://github.com/astroml/astroml#tag=v1.0?signed
+ source = 001-setup.cfg.patch
+ validpgpkeys = 0DD00E57D2FBEBA214389EC58BC1E9224F65DAD4
+ sha256sums = SKIP
+ sha256sums = dbca87eba820555aa95ff6e055d974f553fd3bef14eca0fdc8c28966743d33dd
pkgname = python-astroml
-
diff --git a/001-setup.cfg.patch b/001-setup.cfg.patch
new file mode 100644
index 000000000000..306155c1b0a5
--- /dev/null
+++ b/001-setup.cfg.patch
@@ -0,0 +1,15 @@
+diff --git a/setup.cfg b/setup.cfg
+index d70a302..1421931 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,9 +1,5 @@
+ [tool:pytest]
+-addopts = --doctest-plus
+-doctest_plus = enabled
+-doctest_rst = True
+-testspaths = astroML doc examples
+-doctest_optionflags = FLOAT_CMP ELLIPSIS NORMALIZE_WHITESPACE
++testspaths = astroML
+ filterwarnings =
+ error::DeprecationWarning
+ error::FutureWarning
diff --git a/PKGBUILD b/PKGBUILD
index 7b0292d680c7..7c9ec4470cc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,47 @@
-# Maintainer: Quan Guo <guotsuan@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Quan Guo <guotsuan@gmail.com>
pkgname=python-astroml
_pkgname=astroML
-pkgver=0.3
+pkgver=1.0
pkgrel=1
-pkgdesc="AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib."
-
-url='http://www.astroml.org/'
+pkgdesc='Machine learning, statistics, and data mining for astronomy and astrophysics'
+url='https://www.astroml.org'
arch=('any')
-license=('BSD-3-Clause')
-depends=('python-numpy' 'python-scipy' 'python-scikit-learn'
- 'python-matplotlib')
-
+license=('BSD')
+depends=(
+ 'python>=3.5'
+ 'python-astropy>=3.0'
+ 'python-matplotlib>=3.0'
+ 'python-numpy>=1.13'
+ 'python-scipy>=0.18'
+ 'python-scikit-learn>=0.18')
optdepends=('astroml-examples')
+makedepends=('python-setuptools' 'git')
+checkdepends=('python-pytest-runner')
+source=("$pkgname-$pkgver::git+https://github.com/astroml/astroml#tag=v$pkgver?signed"
+ '001-setup.cfg.patch')
+sha256sums=('SKIP'
+ 'dbca87eba820555aa95ff6e055d974f553fd3bef14eca0fdc8c28966743d33dd')
+validpgpkeys=('0DD00E57D2FBEBA214389EC58BC1E9224F65DAD4')
-source=("https://pypi.python.org/packages/source/a/astroML/astroML-${pkgver}.tar.gz")
+prepare() {
+ patch -p1 -d "$pkgname-$pkgver" < 001-setup.cfg.patch
+}
-md5sums=('56d5c281ca079eb569ef1898be1604db')
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+check() {
+ cd "$pkgname-$pkgver"
+ python setup.py pytest
+}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python ./setup.py install --root="${pkgdir}" --prefix=/usr
+ cd "$pkgname-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.rst -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.rst CITATION -t "$pkgdir/usr/share/doc/$pkgname/"
}