summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-09-21 13:48:44 +0800
committerUniversebenzene2023-09-21 13:48:44 +0800
commit30daa2c3a8fe4eb909426d79600e2d86d48f8a76 (patch)
treea2be0ef4b8d4b3f1828722fb02d427fd085d8580
parent898a113f96940fa7abb708530eaeecc0595f5ebd (diff)
downloadaur-30daa2c3a8fe4eb909426d79600e2d86d48f8a76.tar.gz
Update to version 0.9.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c36640c4cc0e..eb43d4aa84ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-astroplan
pkgdesc = A python package to help astronomers plan observations
- pkgver = 0.9
+ pkgver = 0.9.1
pkgrel = 1
url = https://astroplan.readthedocs.io
arch = any
@@ -8,7 +8,6 @@ pkgbase = python-astroplan
checkdepends = python-pytest-astropy-header
checkdepends = python-pytest-doctestplus
checkdepends = python-pytest-mpl
- checkdepends = python-matplotlib
makedepends = python-setuptools-scm
makedepends = python-wheel
makedepends = python-build
@@ -18,9 +17,9 @@ pkgbase = python-astroplan
makedepends = python-pydata-sphinx-theme
makedepends = python-astroquery
makedepends = graphviz
- source = https://files.pythonhosted.org/packages/source/a/astroplan/astroplan-0.9.tar.gz
+ source = https://files.pythonhosted.org/packages/source/a/astroplan/astroplan-0.9.1.tar.gz
source = fix_doc_index_astropy_link.patch
- md5sums = c79e7c6c8f3d49ba77a29da75b97bf79
+ md5sums = d75b6900656e78ab3ba62c4aadd2b1d3
md5sums = be56be5926b43589b273c16544c5241a
pkgname = python-astroplan
diff --git a/PKGBUILD b/PKGBUILD
index 49c184784307..6d1d92a64c59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-astroplan
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.9
+pkgver=0.9.1
pkgrel=1
pkgdesc="A python package to help astronomers plan observations"
arch=('any')
@@ -19,21 +19,25 @@ makedepends=('python-setuptools-scm'
'graphviz')
checkdepends=('python-pytest-astropy-header'
'python-pytest-doctestplus'
- 'python-pytest-mpl'
- 'python-matplotlib') # six <- .. <- matplotlib; pytz -< .. <- sphinx
-#checkdepends=('python-pytest-doctestplus')
+ 'python-pytest-mpl') # six <- .. <- matplotlib <- pytest-mpl; pytz -< .. <- sphinx; astropy <- astroquery
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
# "http://hpiers.obspm.fr/iers/eop/eopc04/eopc04_IAU2000.62-now"
# "https://skyview.gsfc.nasa.gov/tempspace/fits/skv9820097384828.fits"
'fix_doc_index_astropy_link.patch')
-md5sums=('c79e7c6c8f3d49ba77a29da75b97bf79'
+md5sums=('d75b6900656e78ab3ba62c4aadd2b1d3'
'be56be5926b43589b273c16544c5241a')
+get_pyver() {
+ python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
+}
+
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python -m build --wheel --no-isolation
msg "Building Docs"
+ ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname/-/_}*egg-info \
+ build/lib/${_pyname/-/_}-${pkgver}-py$(get_pyver .).egg-info
PYTHONPATH="../build/lib" make -C docs html
}