summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-02-25 12:06:09 +0800
committerUniversebenzene2019-02-25 12:06:09 +0800
commitc8b5e973cc79d15043c70ec38d6f14e01d527f27 (patch)
tree8fc41a2f28fe530ed97f984824df8a0bd2eae46d
parentf56c680005ae4931b23b8ef96adadc985a5d1624 (diff)
downloadaur-c8b5e973cc79d15043c70ec38d6f14e01d527f27.tar.gz
Add contional before python2 testing
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58ff92ef54bc..9217ce7a944a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Feb 25 02:50:22 UTC 2019
+# Mon Feb 25 04:02:59 UTC 2019
pkgbase = python-astropy-healpix
pkgdesc = BSD-licensed HEALPix for Astropy
pkgver = 0.4
@@ -9,7 +9,10 @@ pkgbase = python-astropy-healpix
arch = x86_64
license = BSD
checkdepends = python-pytest-astropy
+ checkdepends = python2-pytest32
+ checkdepends = python2-healpy
checkdepends = python-healpy
+ checkdepends = python2-hypothesis
checkdepends = python-hypothesis
makedepends = python-setuptools
makedepends = python2-setuptools
@@ -37,9 +40,6 @@ pkgname = python2-astropy-healpix
depends = python2-numpy>=1.10
depends = python2-astropy>=1.2
optdepends = python-astropy-healpix-doc: Documentation for Astropy-HEALPix
- optdepends = python2-pytest32: For testing
- optdepends = python2-hypothesis: For testing
- optdepends = python2-healpy: For testing
pkgname = python-astropy-healpix-doc
pkgdesc = Documentation for AstroPy-HEALPix
diff --git a/PKGBUILD b/PKGBUILD
index 65fa705af221..e1c64d53854c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@ url="http://astropy-healpix.readthedocs.io/"
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers>=3.1' 'python2-astropy-helpers' 'python-sphinx-astropy')
checkdepends=('python-pytest-astropy'
-# 'python2-pytest32'
-# 'python2-healpy'
+ 'python2-pytest32'
+ 'python2-healpy'
'python-healpy'
-# 'python2-hypothesis'
+ 'python2-hypothesis'
'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix_deprecation_warning.patch'
@@ -44,21 +44,20 @@ build() {
}
check() {
-# msg "Checking Python3"
+ msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py test
-# msg "Checking Python2"
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py test
+ if [ -z $(pacman -Qsq python2-pytest-cov) ]; then
+ msg "Checking Python2"
+ cd ${srcdir}/${_pyname}-${pkgver}-py2
+ python2 setup.py test
+ fi
}
package_python2-astropy-healpix() {
depends=('python2>=2.7' 'python2-numpy>=1.10' 'python2-astropy>=1.2')
- optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix'
- 'python2-pytest32: For testing'
- 'python2-hypothesis: For testing'
- 'python2-healpy: For testing')
+ optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix')
install=python2-astropy-healpix.install
cd ${srcdir}/${_pyname}-${pkgver}-py2