summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-02-02 15:45:01 +0800
committerUniversebenzene2018-02-02 15:45:01 +0800
commited3dcd9c38668453f61ce718b8ab00ca8e9d728f (patch)
tree37dd4c358b9ac14d2aba560883e116fe4d0474df
downloadaur-ed3dcd9c38668453f61ce718b8ab00ca8e9d728f.tar.gz
Initial import 0.2
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD23
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3c282f561bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Feb 2 07:42:32 UTC 2018
+pkgbase = python-astropy-healpix
+ pkgdesc = BSD-licensed HEALPix for Astropy
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://astropy-healpix.readthedocs.io/en/latest/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cython
+ depends = python
+ depends = python-numpy>=1.10
+ depends = python-astropy>=1.2
+ optdepends = python-pytest: For testing
+ optdepends = python-healpy: For testing (will be skipped if healpy is not installed while testing)
+ optdepends = python-hypothesis: For the healpy-related tests
+ source = https://files.pythonhosted.org/packages/source/a/astropy-healpix/astropy-healpix-0.2.tar.gz
+ md5sums = 88cbb91e9c4dc61740735c9a9bdaaec5
+
+pkgname = python-astropy-healpix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be37048b780c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-astropy-healpix
+pkgver=0.2
+pkgrel=1
+pkgdesc="BSD-licensed HEALPix for Astropy"
+arch=('i686' 'x86_64')
+url="http://astropy-healpix.readthedocs.io/en/latest/"
+license=('BSD')
+depends=('python' 'python-numpy>=1.10' 'python-astropy>=1.2')
+makedepends=('cython')
+optdepends=('python-pytest: For testing'
+ 'python-healpy: For testing (will be skipped if healpy is not installed while testing)'
+ 'python-hypothesis: For the healpy-related tests')
+source=("https://files.pythonhosted.org/packages/source/a/astropy-healpix/astropy-healpix-${pkgver}.tar.gz")
+md5sums=('88cbb91e9c4dc61740735c9a9bdaaec5')
+
+package() {
+ cd ${srcdir}/astropy-healpix-${pkgver}
+
+ install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+}