summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-11-19 13:19:39 +0800
committerUniversebenzene2019-11-19 13:19:39 +0800
commitcc41e995b191f309b48ee4cbfcb0c9ab57e0ac8f (patch)
tree4771ffb47a3c4909a09a65e983f902ed72b4d492
parent65214dd0f741c607e0ef14b1e58fd29c3ca3b842 (diff)
downloadaur-cc41e995b191f309b48ee4cbfcb0c9ab57e0ac8f.tar.gz
Update for python3.8
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--use_system_astropy_helpers.patch8
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afbc9cc79f2e..f1ce0e2cbc48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-astropy-helpers
pkgdesc = Utilities used for building the Astropy python library for astronomy
pkgver = 3.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://astropy-helpers.readthedocs.io/
arch = any
license = BSD
@@ -9,7 +9,7 @@ pkgbase = python-astropy-helpers
source = https://files.pythonhosted.org/packages/source/a/astropy-helpers/astropy-helpers-3.2.2.tar.gz
source = use_system_astropy_helpers.patch
md5sums = 8e6cee4698f0fe3382e2eb3368d62114
- md5sums = 13cd66eec7da36e18d5db09fe9dfd3a5
+ md5sums = 9b061a3f373546f797fcc658483d7e2b
pkgname = python-astropy-helpers
optdepends = python-astropy-helpers-doc=3.2.2: Documentation for Astropy helpers
diff --git a/PKGBUILD b/PKGBUILD
index db64c28eee74..e341f2014484 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Universebenzene <universebenzene at sina dot com>
pkgname=('python-astropy-helpers')
pkgver=3.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Utilities used for building the Astropy python library for astronomy"
arch=('any')
url="https://astropy-helpers.readthedocs.io/"
@@ -11,7 +11,7 @@ makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/a/astropy-helpers/astropy-helpers-${pkgver}.tar.gz"
'use_system_astropy_helpers.patch')
md5sums=('8e6cee4698f0fe3382e2eb3368d62114'
- '13cd66eec7da36e18d5db09fe9dfd3a5')
+ '9b061a3f373546f797fcc658483d7e2b')
prepare() {
cd ${srcdir}/astropy-helpers-${pkgver}
diff --git a/use_system_astropy_helpers.patch b/use_system_astropy_helpers.patch
index 45e27372e3a8..5885b92aa88a 100644
--- a/use_system_astropy_helpers.patch
+++ b/use_system_astropy_helpers.patch
@@ -1,11 +1,11 @@
---- a/astropy_helpers/commands/build_sphinx.py 2018-12-05 10:10:37.000000000 +0800
-+++ b/astropy_helpers/commands/build_sphinx.py 2018-12-05 15:15:31.598247890 +0800
-@@ -162,7 +162,7 @@
+--- a/astropy_helpers/commands/build_sphinx.py 2019-10-27 07:50:58.000000000 +0800
++++ b/astropy_helpers/commands/build_sphinx.py 2019-11-19 13:15:32.433597270 +0800
+@@ -143,7 +143,7 @@
build_cmd = self.get_finalized_command('build')
build_cmd_path = os.path.abspath(build_cmd.build_lib)
- ah_importer = pkgutil.get_importer('astropy_helpers')
-+ ah_importer = pkgutil.get_importer('/usr/lib/python3.7/site-packages/astropy_helpers')
++ ah_importer = pkgutil.get_importer('/usr/lib/python3.8/site-packages/astropy_helpers')
if ah_importer is None:
ah_path = '.'
else: