summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel de Val-Borro2018-02-06 11:07:13 -0500
committerMiguel de Val-Borro2018-02-06 11:07:13 -0500
commitd3cc2bcb02f3e55adebb41743efdfdfd65c645c1 (patch)
tree76ebf7d43501d1b8c2499b635c447fd67f66328c
parenta73e069600d8a7a523202dc6c7bc0d983b02097b (diff)
downloadaur-d3cc2bcb02f3e55adebb41743efdfdfd65c645c1.tar.gz
patch to build astropy docs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--astropy_helpers.patch11
3 files changed, 15 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63d5fa33ef56..2b5f6d8b81b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-astropy-helpers
pkgdesc = Utilities used for building the Astropy python library for astronomy
pkgver = 2.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/astropy/astropy-helpers
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index f3fdea1be241..df8bd2a2d0b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Miguel de Val-Borro <miguel.deval at gmail dot com>
+# Contributor: Universebenzene <universebenzene at sina dot com>
pkgname=('python-astropy-helpers')
pkgver=2.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="Utilities used for building the Astropy python library for astronomy"
arch=('any')
url="https://github.com/astropy/astropy-helpers"
@@ -12,6 +13,7 @@ md5sums=('8129ddec049865e7401d1a7e86b3a22b')
build() {
cd ${srcdir}/astropy-helpers-${pkgver}
+ patch -p1 -i ../../astropy_helpers.patch
python setup.py build --use-system-libraries
}
diff --git a/astropy_helpers.patch b/astropy_helpers.patch
new file mode 100644
index 000000000000..0f924167ac1d
--- /dev/null
+++ b/astropy_helpers.patch
@@ -0,0 +1,11 @@
+--- a/astropy_helpers/commands/build_sphinx.py 2017-10-12 03:56:31.000000000 +0800
++++ b/astropy_helpers/commands/build_sphinx.py 2018-02-06 21:49:54.599865388 +0800
+@@ -126,7 +126,7 @@
+ build_cmd = self.get_finalized_command('build')
+ build_cmd_path = os.path.abspath(build_cmd.build_lib)
+
+- ah_importer = pkgutil.get_importer('astropy_helpers')
++ ah_importer = pkgutil.get_importer('/usr/lib/python3.6/site-packages/astropy_helpers')
+ ah_path = os.path.abspath(ah_importer.path)
+
+ # Now generate the source for and spawn a new process that runs the