summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-09-09 17:39:47 +0800
committerUniversebenzene2018-09-09 17:39:47 +0800
commit915dd74cfd575c3f3eaa79143f6d620d49cae01f (patch)
tree20928b529ab4408456fe36d09b5b334f05705929
downloadaur-915dd74cfd575c3f3eaa79143f6d620d49cae01f.tar.gz
Initial import 1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7a3153d89ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Sep 9 09:36:52 UTC 2018
+pkgbase = python-astropy-sphinx-theme
+ pkgdesc = The sphinx theme for Astropy and affiliated packages.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/astropy/astropy-sphinx-theme
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-sphinx>=1.6
+ source = https://files.pythonhosted.org/packages/source/a/astropy-sphinx-theme/astropy-sphinx-theme-1.0.tar.gz
+ sha256sums = f7e5734bca4bfd62769b2516f2b80a3dc9f950ef67066706579a086d2b2162bc
+
+pkgname = python-astropy-sphinx-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f52ad93a272
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Chris Severance aur.severach AatT spamgourmet.com
+
+pkgname=python-astropy-sphinx-theme
+pkgver=1.0
+pkgrel=1
+pkgdesc="The sphinx theme for Astropy and affiliated packages."
+arch=('any')
+url="https://github.com/astropy/astropy-sphinx-theme"
+license=('BSD')
+depends=('python-sphinx>=1.6')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/a/astropy-sphinx-theme/astropy-sphinx-theme-${pkgver}.tar.gz")
+sha256sums=('f7e5734bca4bfd62769b2516f2b80a3dc9f950ef67066706579a086d2b2162bc')
+
+package() {
+ cd ${srcdir}/astropy-sphinx-theme-${pkgver}
+
+ install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}