summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-02-02 15:22:41 +0800
committerUniversebenzene2018-02-02 15:22:41 +0800
commit16238b89e503ea8d98f17c27840e49c268eb7080 (patch)
tree85d41f9ebe73a8b4cffed3f06b9e917e7d724dc2
downloadaur-16238b89e503ea8d98f17c27840e49c268eb7080.tar.gz
Initial import 1.0.5
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e09928c31431
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 2 06:59:40 UTC 2018
+pkgbase = python-astroscrappy
+ pkgdesc = Speedy Cosmic Ray Annihilation Package in Python
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/astropy/astroscrappy
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python
+ depends = python-numpy
+ depends = python-astropy
+ depends = cython>=0.21
+ source = https://files.pythonhosted.org/packages/source/a/astroscrappy/astroscrappy-1.0.5.tar.gz
+ md5sums = e7ec5d829191226e6092b08e1d8f4cd4
+
+pkgname = python-astroscrappy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88c9907ad9de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-astroscrappy
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Speedy Cosmic Ray Annihilation Package in Python"
+arch=('i686' 'x86_64')
+url="https://github.com/astropy/astroscrappy"
+license=('BSD')
+depends=('python' 'python-numpy' 'python-astropy' 'cython>=0.21')
+source=("https://files.pythonhosted.org/packages/source/a/astroscrappy/astroscrappy-${pkgver}.tar.gz")
+md5sums=('e7ec5d829191226e6092b08e1d8f4cd4')
+
+package() {
+ cd ${srcdir}/astroscrappy-${pkgver}
+
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+}