summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoratomlong2021-11-08 22:23:07 +0800
committeratomlong2021-11-08 22:23:07 +0800
commit4a5e5459f73f6e1cd9f5d2db4396eeae35d94a2c (patch)
treebcb5c7cdea88655b4c15b044cbf8a3ea42748ec4
downloadaur-4a5e5459f73f6e1cd9f5d2db4396eeae35d94a2c.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5518853620d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-async-timeout-git
+ pkgdesc = Asyncio-compatible timeout class
+ pkgver = 4.0.0.r2.g77f0cba
+ pkgrel = 1
+ url = https://github.com/aio-libs/async-timeout
+ arch = any
+ license = Apache
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ checkdepends = python-pytest-asyncio
+ checkdepends = python-pytest-aiohttp
+ makedepends = python-setuptools
+ depends = python
+ provides = python-async-timeout
+ conflicts = python-async-timeout
+ source = async-timeout::git+https://github.com/aio-libs/async-timeout
+ sha256sums = SKIP
+
+pkgname = python-async-timeout-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5e7686a2c66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Stunts <f.pinamartins[at]gmail.com>
+# Contributor: Phil Schaf <flying-sheep[at]web.de>
+# Contributor: Carl George < arch at cgtx dot us >
+
+_pkgname=async-timeout
+pkgname=python-${_pkgname}-git
+pkgver=4.0.0.r2.g77f0cba
+pkgrel=1
+pkgdesc='Asyncio-compatible timeout class'
+url='https://github.com/aio-libs/async-timeout'
+arch=('any')
+license=('Apache')
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-asyncio' 'python-pytest-aiohttp')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(${_pkgname}::git+${url})
+sha256sums=('SKIP')
+
+build() {
+ cd ${_pkgname}
+ python setup.py build
+}
+
+check() {
+ cd ${_pkgname}
+ PYTHONPATH=. py.test tests
+}
+
+
+package() {
+ cd ${_pkgname}
+ python setup.py install --root="${pkgdir}" -O1 --skip-build
+}
+
+# vim: ts=2 sw=2 et: