summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpotatoattack2024-04-09 11:05:20 +1000
committerpotatoattack2024-04-09 11:05:20 +1000
commit404de6973ef20cd337bc886997214b751cf4523e (patch)
treef5ab5f41cb927e351f164f880cbcd1e21f7345b8
downloadaur-404de6973ef20cd337bc886997214b751cf4523e.tar.gz
initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52e3ae4f35e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-async_interrupt
+ pkgdesc = Python library that provides happy eyeballs algorithm for asyncio.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/bdraco/async_interrupt
+ arch = any
+ license = MIT
+ makedepends = python-poetry
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/a/async_interrupt/async_interrupt-1.1.1.tar.gz
+ sha256sums = 1e5999f0980b5db21293e4cd022518eeaf52284c0499631932a1df250cb99215
+
+pkgname = python-async_interrupt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9371036d42e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Aaron Coach <aur at ezpz.cz>
+
+pkgname=python-async_interrupt
+_pkgname=async_interrupt
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Python library that provides happy eyeballs algorithm for asyncio."
+arch=('any')
+url="https://github.com/bdraco/async_interrupt"
+license=('MIT')
+depends=('python')
+makedepends=('python-poetry')
+source=("https://files.pythonhosted.org/packages/source/a/async_interrupt/async_interrupt-${pkgver}.tar.gz")
+sha256sums=('1e5999f0980b5db21293e4cd022518eeaf52284c0499631932a1df250cb99215')
+
+build() {
+ cd $_pkgname-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}