summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12020-01-29 18:23:54 +0500
committerevgfilim12020-01-29 18:23:54 +0500
commitc7495e2123b5aeecf263284973f7dededf710ce9 (patch)
tree486657cc6f93dc828d54b0caeea7140ffaab4229
downloadaur-c7495e2123b5aeecf263284973f7dededf710ce9.tar.gz
Initial commit, v1.0.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ed8ed680bc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-async_lru
+ pkgdesc = Simple lru_cache for asyncio
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/aio-libs/async_lru
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-async-lru
+ conflicts = python-async-lru
+ source = https://files.pythonhosted.org/packages/source/a/async_lru/async_lru-1.0.2.tar.gz
+ sha256sums = baa898027619f5cc31b7966f96f00e4fc0df43ba206a8940a5d1af5336a477cb
+
+pkgname = python-async_lru
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54309f12d23c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
+
+pkgname=python-async_lru
+_module='async_lru'
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Simple lru_cache for asyncio"
+url="https://github.com/aio-libs/async_lru"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+provides=('python-async-lru')
+conflicts=('python-async-lru')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.tar.gz")
+sha256sums=('baa898027619f5cc31b7966f96f00e4fc0df43ba206a8940a5d1af5336a477cb')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}