summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Azzam2020-11-08 18:29:07 +0100
committerKevin Azzam2020-11-08 18:29:07 +0100
commit5217c0657c28abdf6424bebca9383c86dc915735 (patch)
treea5f36a86c46c135ab0d66ba04c76ba06be5ff131
downloadaur-5217c0657c28abdf6424bebca9383c86dc915735.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d45e0c07545
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-asyncio-glib
+ pkgdesc = GLib event loop integration for asyncio.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/jhenstridge/asyncio-glib
+ arch = any
+ license = LGPL
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/a/asyncio-glib/asyncio-glib-0.1.tar.gz
+ sha256sums = fe3ceb2ba5f541330c07ca1bd7ae792468d625bad1acf5354a3a7a0b9fd87521
+
+pkgname = python-asyncio-glib
+ depends = gobject-introspection
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2625e00e35a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0089d8b1cab7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kevin Azzam <aur@azz.am>
+
+pkgname='python-asyncio-glib'
+_module='asyncio-glib'
+pkgver='0.1'
+pkgrel=1
+pkgdesc="GLib event loop integration for asyncio."
+url="https://github.com/jhenstridge/asyncio-glib"
+makedepends=('python-setuptools')
+license=('LGPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/a/asyncio-glib/asyncio-glib-${pkgver}.tar.gz")
+sha256sums=('fe3ceb2ba5f541330c07ca1bd7ae792468d625bad1acf5354a3a7a0b9fd87521')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends=('gobject-introspection')
+
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm 644 COPYING.LGPL "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.LGPL"
+}