summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2019-02-25 11:08:20 -0500
committerDrew DeVault2019-02-25 11:08:20 -0500
commit0ddaecc62f4ba791be55c41a1813fc6e6d86ae99 (patch)
treedab6f4959df028d7a624914d15528e689bf6b982
parenta5eaecd112893edc59e0c61ab3fb8f9e319e4260 (diff)
downloadaur-0ddaecc62f4ba791be55c41a1813fc6e6d86ae99.tar.gz
Update to 0.15.1; clean up PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0a95749bc9f..c427cdb1825f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Jul 8 14:23:01 UTC 2017
pkgbase = python-asyncio_redis
pkgdesc = PEP 3156 implementation of the redis protocol.
- pkgver = 0.14.3
+ pkgver = 0.15.1
pkgrel = 1
url = https://pypi.python.org/pypi/asyncio_redis
arch = any
- license = 2 clause BSD
- makedepends = python-distribute
+ license = BSD-2-Clause
+ makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/a/asyncio_redis/asyncio_redis-0.14.3.tar.gz
- sha256sums = fae40dc59c7268dfb9a44542cb3f48a885c8f5f7438b13f0dfec1fbd10a82369
+ source = python-asyncio_redis-0.15.1.tar.gz::https://files.pythonhosted.org/packages/source/a/asyncio_redis/asyncio_redis-0.15.1.tar.gz
+ sha256sums = 067dbc251ab84d6e53ef8b33dbfd8afd62987ab08f72ca922f6870c96be53b54
pkgname = python-asyncio_redis
diff --git a/PKGBUILD b/PKGBUILD
index ba92bd94f6e3..085a8d2d4fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname="python-asyncio_redis"
-_name=asyncio_redis
-pkgver=0.14.3
+_pkgname=asyncio_redis
+pkgver=0.15.1
pkgrel=1
pkgdesc="PEP 3156 implementation of the redis protocol."
arch=("any")
url="https://pypi.python.org/pypi/asyncio_redis"
-license=("2 clause BSD")
+license=("BSD-2-Clause")
depends=("python")
-makedepends=("python-distribute")
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('fae40dc59c7268dfb9a44542cb3f48a885c8f5f7438b13f0dfec1fbd10a82369')
+makedepends=("python-setuptools")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('067dbc251ab84d6e53ef8b33dbfd8afd62987ab08f72ca922f6870c96be53b54')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$_pkgname-$pkgver"
python ./setup.py build
}
package() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}