summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-05-10 22:00:21 -0400
committerGuillaume Horel2020-05-10 22:00:21 -0400
commit3e71b109e0a8d6cfbea9ae57f32188fdf9b0ace2 (patch)
treecafb710ccebacbb13f0e9c5dd84c5679d85cf395
parenta499dcd7c462d60d8b2f26510117287cdadcbfe2 (diff)
downloadaur-3e71b109e0a8d6cfbea9ae57f32188fdf9b0ace2.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--fix-test.patch14
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92c4f197dd92..5cafd269b7e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-asyncpg
pkgdesc = An asyncio PosgtreSQL driver
- pkgver = 0.20.0
+ pkgver = 0.20.1
pkgrel = 1
url = https://github.com/MagicStack/asyncpg
arch = x86_64
@@ -9,10 +9,12 @@ pkgbase = python-asyncpg
checkdepends = postgresql
makedepends = python-setuptools
makedepends = cython
- source = https://pypi.org/packages/source/a/asyncpg/asyncpg-0.20.0.tar.gz
+ source = https://pypi.org/packages/source/a/asyncpg/asyncpg-0.20.1.tar.gz
source = remove-package-data.patch
- sha256sums = aa02dce5d5b801cff7dd2d99b767f5db312858f527ec1764777aad1fdefb5a7a
+ source = fix-test.patch
+ sha256sums = 394bf19bdddbba07a38cd6fb526ebf66e120444d6b3097332b78efd5b26495b0
sha256sums = fbd60ee542f87222d26b69095d3c5bd70863f8a066eb56035902d1ded836659d
+ sha256sums = 93d64b7bdea356576536ebe32b5a01930130ac58e6eb414a18661fc57b487e64
pkgname = python-asyncpg
diff --git a/PKGBUILD b/PKGBUILD
index 6af7926323fe..0210e0013c96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="python-asyncpg"
_pkgname="asyncpg"
-pkgver="0.20.0"
+pkgver="0.20.1"
pkgrel="1"
pkgdesc="An asyncio PosgtreSQL driver"
arch=("x86_64")
@@ -13,13 +13,16 @@ makedepends=("python-setuptools" "cython")
checkdepends=("python-pytest"
'postgresql')
source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
- remove-package-data.patch)
-sha256sums=('aa02dce5d5b801cff7dd2d99b767f5db312858f527ec1764777aad1fdefb5a7a'
- 'fbd60ee542f87222d26b69095d3c5bd70863f8a066eb56035902d1ded836659d')
+ remove-package-data.patch
+ fix-test.patch)
+sha256sums=('394bf19bdddbba07a38cd6fb526ebf66e120444d6b3097332b78efd5b26495b0'
+ 'fbd60ee542f87222d26b69095d3c5bd70863f8a066eb56035902d1ded836659d'
+ '93d64b7bdea356576536ebe32b5a01930130ac58e6eb414a18661fc57b487e64')
prepare() {
cd "$_pkgname-$pkgver"
patch -p1 -i ../remove-package-data.patch
+ patch -p1 < ../fix-test.patch
}
build() {
@@ -35,5 +38,5 @@ package() {
check() {
cd "$_pkgname-$pkgver"
python setup.py build_ext --inplace
- pytest
+ python setup.py test
}
diff --git a/fix-test.patch b/fix-test.patch
new file mode 100644
index 000000000000..0f0c6ba16974
--- /dev/null
+++ b/fix-test.patch
@@ -0,0 +1,14 @@
+diff -urN asyncpg-0.20.1-orig/tests/test_pool.py asyncpg-0.20.1/tests/test_pool.py
+--- asyncpg-0.20.1-orig/tests/test_pool.py 2020-05-10 21:55:48.209528164 -0400
++++ asyncpg-0.20.1/tests/test_pool.py 2020-05-10 21:56:23.459966715 -0400
+@@ -242,8 +242,8 @@
+
+ with self.assertRaisesRegex(
+ asyncpg.InterfaceError,
+- r'cannot call Cursor\.forward.*released '
+- r'back to the pool'.format(meth=meth)):
++ r'cannot call Cursor\.{meth}.*released '
++ r'back to the pool'.format(meth='forward')):
+
+ c.forward(1)
+