summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2017-05-13 13:48:20 -0500
committercarlwgeorge2017-05-13 14:25:25 -0500
commit5e8c355a3e5a81ebc641ccb6c37c16def126e4b9 (patch)
treedade6cccbc5e582af146b3ef88e399eff9bcc50c
parent82472e1e3982ad0b43befdaca394f87b545c44e6 (diff)
downloadaur-5e8c355a3e5a81ebc641ccb6c37c16def126e4b9.tar.gz
0.11.0-1
* add patch to remove package data (https://github.com/MagicStack/asyncpg/pull/141)
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
-rw-r--r--remove-package-data.patch14
4 files changed, 36 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2efabe168f5..8e181a29d4fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Apr 7 22:01:14 UTC 2017
+# Sat May 13 19:25:17 UTC 2017
pkgbase = python-asyncpg
pkgdesc = An asyncio PosgtreSQL driver
- pkgver = 0.10.1
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/MagicStack/asyncpg
arch = i686
@@ -10,8 +10,10 @@ pkgbase = python-asyncpg
license = Apache
makedepends = python-setuptools
makedepends = cython
- source = https://github.com/MagicStack/asyncpg/archive/v0.10.1.tar.gz
- sha256sums = 4e9d3c3abdfb7e2bb46ea23d232622a9a2488320c5e8ef49a53c732118f549fa
+ source = https://github.com/MagicStack/asyncpg/archive/v0.11.0.tar.gz
+ source = remove-package-data.patch
+ sha256sums = 01da0c5e4f4f93b45fceccb7764928ed2fe1770c540a246d8414f34532de7cc3
+ sha256sums = 8ffcda406cd5f92743bfb57b7213ed976876e2d9ecbf5d7e439313de90bd22ad
pkgname = python-asyncpg
depends = python
diff --git a/.gitignore b/.gitignore
index 213d7dad80c7..71210bc43107 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,6 +5,7 @@
*-build.log
*-namcap.log
*-package*.log
+*-prepare.log
# packages
*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 377763bcff82..af9bba75b9fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,31 @@
# Maintainer: Carl George < arch at cgtx dot us >
_name="asyncpg"
-pkgname="python-${_name}"
-pkgver="0.10.1"
+pkgname="python-$_name"
+pkgver="0.11.0"
pkgrel="1"
pkgdesc="An asyncio PosgtreSQL driver"
arch=("i686" "x86_64")
-url="https://github.com/MagicStack/${_name}"
+url="https://github.com/MagicStack/$_name"
license=("Apache")
makedepends=("python-setuptools" "cython")
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('4e9d3c3abdfb7e2bb46ea23d232622a9a2488320c5e8ef49a53c732118f549fa')
+source=("$url/archive/v$pkgver.tar.gz"
+ remove-package-data.patch)
+sha256sums=('01da0c5e4f4f93b45fceccb7764928ed2fe1770c540a246d8414f34532de7cc3'
+ '8ffcda406cd5f92743bfb57b7213ed976876e2d9ecbf5d7e439313de90bd22ad')
+
+prepare() {
+ cd "$_name-$pkgver"
+ patch -p1 -i ../remove-package-data.patch
+}
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$_name-$pkgver"
python setup.py build
}
package() {
depends=("python")
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ cd "$_name-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
}
diff --git a/remove-package-data.patch b/remove-package-data.patch
new file mode 100644
index 000000000000..036a45f6c4c2
--- /dev/null
+++ b/remove-package-data.patch
@@ -0,0 +1,14 @@
+diff -Naurp a/setup.py b/setup.py
+--- a/setup.py 2017-05-11 15:50:10.000000000 -0500
++++ b/setup.py 2017-05-13 14:13:26.535829162 -0500
+@@ -202,9 +202,8 @@ setuptools.setup(
+ author_email='hello@magic.io',
+ url='https://github.com/MagicStack/asyncpg',
+ license='Apache License, Version 2.0',
+- packages=['asyncpg'],
++ packages=setuptools.find_packages(),
+ provides=['asyncpg'],
+- include_package_data=True,
+ ext_modules=[
+ setuptools.Extension(
+ "asyncpg.protocol.protocol",