summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2023-01-06 23:09:47 +0100
committerMassimiliano Torromeo2023-01-06 23:09:47 +0100
commit3e42feac9ef52cdbbddf193230422d6055cbb80d (patch)
treef213fba7204f84fb03224cfe4104b73903f7f294
parentaa8b201137283d8a9a5f6d2adadd7654f4e3b715 (diff)
downloadaur-3e42feac9ef52cdbbddf193230422d6055cbb80d.tar.gz
Updated to 2.13.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d976fc09512b..95960c481b77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-asyncssh
pkgdesc = Asynchronous SSHv2 client and server library
- pkgver = 2.12.0
+ pkgver = 2.13.0
pkgrel = 1
url = http://asyncssh.readthedocs.org/
arch = any
license = EPL
makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
depends = python
- source = https://files.pythonhosted.org/packages/source/a/asyncssh/asyncssh-2.12.0.tar.gz
- sha256sums = 274101322c4b941823aeed8e1ab6e7be5191686c6db2d2bd35afeba30505e780
+ source = https://files.pythonhosted.org/packages/source/a/asyncssh/asyncssh-2.13.0.tar.gz
+ sha256sums = be7e1cb47225dc9899e56472fdc4daac03584a6843675329c0ce67179cb20e29
pkgname = python-asyncssh
diff --git a/PKGBUILD b/PKGBUILD
index ca922d6291cb..19e3ab6bda99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=python-asyncssh
-pkgver=2.12.0
+pkgver=2.13.0
pkgrel=1
pkgdesc="Asynchronous SSHv2 client and server library"
arch=(any)
url="http://asyncssh.readthedocs.org/"
license=('EPL')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-wheel' 'python-build' 'python-installer')
source=("https://files.pythonhosted.org/packages/source/a/asyncssh/asyncssh-$pkgver.tar.gz")
-sha256sums=('274101322c4b941823aeed8e1ab6e7be5191686c6db2d2bd35afeba30505e780')
+sha256sums=('be7e1cb47225dc9899e56472fdc4daac03584a6843675329c0ce67179cb20e29')
build() {
cd "$srcdir"/asyncssh-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir"/asyncssh-$pkgver
- python setup.py install -O1 --skip-build --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}