summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-07-13 13:43:40 +0100
committerFFY002018-07-13 13:43:40 +0100
commite188fac27ead18cdfc15582cc09f9e8015476076 (patch)
tree4ac7e4a41afd6adb8d8fdb922a30b7a5e6374ba1
downloadaur-e188fac27ead18cdfc15582cc09f9e8015476076.tar.gz
pkgbuild: initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..107a026327ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-asynctest
+ pkgdesc = Enhance the standard unittest package with features for testing asyncio libraries.
+ pkgver = 0.12.2
+ pkgrel = 1
+ url = https://github.com/Martiusweb/asynctest
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = python-pyserial
+ depends = python-pyusb
+ provides = pylms7002m
+ conflicts = pylms7002m
+ source = python-asynctest-0.12.2.tar.gz::https://github.com/Martiusweb/asynctest/archive/v0.12.2.tar.gz
+ sha256sums = 5506e9462d627dc533a407168fe82183623993a4e0336e5805caba75920eb579
+
+pkgname = python-asynctest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2773d346cafd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Filipe LaĆ­ns (FFY00) <filipe.lains@gmail.com>
+pkgname=python-asynctest
+_pkgname=${pkgname#python-}
+pkgver=0.12.2
+pkgrel=1
+pkgdesc="Enhance the standard unittest package with features for testing asyncio libraries."
+arch=('any')
+url="https://github.com/Martiusweb/asynctest"
+license=('Apache')
+depends=('python-pyserial' 'python-pyusb')
+makedepends=('git')
+provides=('pylms7002m')
+conflicts=('pylms7002m')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('5506e9462d627dc533a407168fe82183623993a4e0336e5805caba75920eb579')
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}