summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2022-06-09 07:29:38 -0700
committerDonald Webster2022-06-09 07:29:38 -0700
commitba1d81e9d9cbc1641c2348bec6316bf6fe91a588 (patch)
tree6fd459cde945a74ef6d672e563da617cafe27fdf
parentb3bffc3f5c3e964615c0eda50c369fa7aff05462 (diff)
downloadaur-python-attrdict.tar.gz
Do s/collections/collections.abc on all .py files.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f68300c1887..f8b0d3232544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-attrdict
pkgdesc = A library that provides mapping objects that allow their elements to be accessed both as keys and as attributes.
pkgver = 2.0.1
- pkgrel = 4
+ pkgrel = 5
url = https://pypi.org/project/attrdict/
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 56faad20623c..ecdff011903d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=python-attrdict
pkgname='python-attrdict'
_name=${pkgname#python-}
pkgver=2.0.1
-pkgrel=4
+pkgrel=5
pkgdesc='A library that provides mapping objects that allow their elements to be accessed both as keys and as attributes.'
arch=('any')
url='https://pypi.org/project/attrdict/'
@@ -15,5 +15,9 @@ sha256sums=('35c90698b55c683946091177177a9e9c0713a0860f0e049febd72649ccd77b70')
package() {
cd attrdict-${pkgver}
+
+ # Fix from https://aur.archlinux.org/packages/python-attrdict#comment-855840 for Python 10.
+ find "${srcdir}/attrdict-${pkgver}" -type f -iname '*.py' -exec sed -i 's/collections/collections.abc/g' {} +
+
python setup.py install --root="$pkgdir" --optimize=1
}